what's thi problem when use the source?

为当前最终发行版之前的所有版本提供支持
回复
scropio
帖子: 1
注册时间: 2005-12-08 9:10
送出感谢: 0
接收感谢: 0

what's thi problem when use the source?

#1

帖子 scropio » 2005-12-08 10:05

scorpio@ubuntu:~$ sudo apt-get update
E: Could not get lock /var/lib/apt/lists/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the list director
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2005-12-08 10:15

就是有2个程序都在操作apt-get的lock文件。关闭一个就可以了。
● 鸣学
头像
andrewlee
帖子: 6
注册时间: 2007-04-15 22:41
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 andrewlee » 2007-05-07 21:02

我的也出现这样的问题。
但怎样关闭那个lock文件?
等待回答。。。。
头像
andrewlee
帖子: 6
注册时间: 2007-04-15 22:41
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 andrewlee » 2007-05-07 21:13

刚才找一个blog,按照上面所说的,执行了
#apt-get autoclean //清理旧版本的软件缓冲
就可以了。
不知是什么原因
vikv
帖子: 174
注册时间: 2006-06-16 15:42
送出感谢: 0
接收感谢: 0

#5

帖子 vikv » 2007-05-07 21:14

Q: 为什么我用apt-get的时候会出现这样的情况
引用:
E: 无法获得锁 /var/cache/apt/archives/lock - open (11 Resource temporarily unavailable)

A: 你一定把新立得/软件更新/添加删除 等与软件安装相关的程序打开了,请把他们关掉吧。apt-get在同一时刻只能有一个在执行。
头像
andrewlee
帖子: 6
注册时间: 2007-04-15 22:41
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 andrewlee » 2007-05-07 21:31

我刚才也是出现这样的问题,不过,我用了
apt-get autoclean就好了
回复

回到 “老旧版本支持”