[问题]flex是什么?

为当前最终发行版之前的所有版本提供支持
回复
teloon
帖子: 12
注册时间: 2007-05-20 20:58
送出感谢: 0
接收感谢: 0
联系:

[问题]flex是什么?

#1

帖子 teloon » 2007-08-19 10:14

昨天装一个软件的时候./configure后遇到下面的问题,错误代码见最后。

网上查到有什么“FLEX 2.01 全套下载:客户端:
Flex Builder 2 with Charting (集成 Flex Builder 2 + Flex 2 SDK + Flex 2 Charting, 大小:168.78MB)

Flex Builder 2 Eclipse plug-in (集成 Flex Builder 2 + Flex 2 SDK + Flex 2 Charting 作为 Eclipse 的插件, 大小:168.78MB)

Flex Builder 2.01 Updater (Flex Builder 重要更新 2.01, 大小:144MB)

服务器端:

Flex Data Services 2 Express (完全免费, 但只能用于单核心CPU电脑上, 大小:93.73MB)

组件单独下载:
Flex 2 SDK (包含 Flex 2 所有组件的类库 和 Flex编译器, 大小:38.07MB)

Flex Charting 2 (Flex 2 图表组件, 大小:17.04MB)

Flex Automation Package (Flex 测试包, 仅提供给 Flex Data Services 2 企业版用户使用, 大小:104.24MB)”

Ⅰ这么多而且又这么大,我该下载哪个啊?
Ⅱ我就只缺这个flex吗?

十分感谢!

./configure后的结果:
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for cpp... cpp
checking for the directory containing the Wine tools... $(TOPOBJDIR)
checking how to run the C preprocessor... gcc -E
checking for X... no
checking for flex... no
configure: error: no suitable flex found. Please install the 'flex' package.
头像
wewe
帖子: 357
注册时间: 2006-05-26 23:40
来自: http://ubuntufans.com
送出感谢: 0
接收感谢: 0

#2

帖子 wewe » 2007-08-19 10:24

终端运行 sudo apt-get install flex 安装即可
装软件都优先考虑apt-get的方式,没有了,或者实在需要新版本再考虑学习用编译安装也不迟
头像
wewe
帖子: 357
注册时间: 2006-05-26 23:40
来自: http://ubuntufans.com
送出感谢: 0
接收感谢: 0

#3

帖子 wewe » 2007-08-19 10:27

对了,在编译这种办法以前还可以找 deb包,总之编译只是最后万不得已才需要用的,至少我是,呵呵
teloon
帖子: 12
注册时间: 2007-05-20 20:58
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 teloon » 2007-08-19 12:17

wewe 写了:终端运行 sudo apt-get install flex 安装即可
装软件都优先考虑apt-get的方式,没有了,或者实在需要新版本再考虑学习用编译安装也不迟


但是我在ubuntu下不能上网啊。。。。
showboy
帖子: 122
注册时间: 2006-11-26 14:41
送出感谢: 0
接收感谢: 0

#5

帖子 showboy » 2007-10-03 20:00

建议安装的软件包:
bison
下列【新】软件包将被安装:
flex
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 304kB 的软件包。
解压缩后会消耗掉 1360kB 的额外空间。
squant
帖子: 24
注册时间: 2008-01-29 13:24
送出感谢: 0
接收感谢: 0

#6

帖子 squant » 2008-01-29 13:27

jiangxuan
帖子: 7
注册时间: 2009-08-16 21:10
送出感谢: 0
接收感谢: 0

Re:

#7

帖子 jiangxuan » 2009-08-22 13:48

wewe 写了:终端运行 sudo apt-get install flex 安装即可
装软件都优先考虑apt-get的方式,没有了,或者实在需要新版本再考虑学习用编译安装也不迟
然后sudo apt-get install bison
:em11 我就是这样的
jayctu
帖子: 1
注册时间: 2009-10-24 11:41
送出感谢: 0
接收感谢: 0

Re: Re:

#8

帖子 jayctu » 2009-11-17 8:42

jiangxuan 写了:
wewe 写了:终端运行 sudo apt-get install flex 安装即可
装软件都优先考虑apt-get的方式,没有了,或者实在需要新版本再考虑学习用编译安装也不迟
然后sudo apt-get install bison
:em11 我就是这样的
强烈支持
回复

回到 “老旧版本支持”