[问题]装了EVA,解决中文输入后系统的输入法不见了

为当前最终发行版之前的所有版本提供支持
回复
ivenom
帖子: 7
注册时间: 2007-08-20 1:40
送出感谢: 0
接收感谢: 0

[问题]装了EVA,解决中文输入后系统的输入法不见了

#1

帖子 ivenom » 2007-08-20 1:52

现在的情况是在EVA下才会启动输入法也可以 输入中文,系统启动没有输入法也不能输入中文,只能打英文了,该怎么办 。

用的就是下面这个的方法改的EVA中文输入

$ sudo gedit /etc/X11/xinit/xinput.d/zh_CN

先看如果不是 XIM_PROGRAM=/usr/bin/scim,就改为XIM_PROGRAM=/usr/bin/scim;再把QT_IM_MODULE= "scim"改为QT_IM_MODULE="xim",保存退出,然后重启Xwindows之后问题就解决了。
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 skyx » 2007-08-20 2:05

gnome上用eva ,解决输入法,只要安装一个qtimm就行的。
no security measure is worth anything if an attacker has physical access to the machine
ivenom
帖子: 7
注册时间: 2007-08-20 1:40
送出感谢: 0
接收感谢: 0

#3

帖子 ivenom » 2007-08-20 2:15

现在的问题是把系统输入法找回来,我现在快崩溃了
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#4

帖子 skyx » 2007-08-20 2:18

原来怎么改的,再改回去。
no security measure is worth anything if an attacker has physical access to the machine
ivenom
帖子: 7
注册时间: 2007-08-20 1:40
送出感谢: 0
接收感谢: 0

#5

帖子 ivenom » 2007-08-20 5:13

试过了 没用啊
头像
bones7456
论坛版主
帖子: 8495
注册时间: 2006-04-12 20:05
来自: 杭州
送出感谢: 0
接收感谢: 8 次
联系:

#6

帖子 bones7456 » 2007-08-20 9:11

那就用fcitx喽~
关注我的blog: ε==3
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#7

帖子 skyx » 2007-08-20 9:14

bones7456 写了:那就用fcitx喽~


汗,还是两个输入法都装上吧。
no security measure is worth anything if an attacker has physical access to the machine
ivenom
帖子: 7
注册时间: 2007-08-20 1:40
送出感谢: 0
接收感谢: 0

#8

帖子 ivenom » 2007-08-20 13:58

有没有什么代码可以恢复的
ivenom
帖子: 7
注册时间: 2007-08-20 1:40
送出感谢: 0
接收感谢: 0

#9

帖子 ivenom » 2007-08-20 22:38

救命啊 我快崩溃了
头像
adqin
帖子: 1417
注册时间: 2007-01-24 22:07
来自: http://adqin.cn
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 adqin » 2007-08-20 22:48

用fcitx算了。
安装fcitx:
sudo apt-get install im-switch fcitx

切换到fcitx:
$im-switch fctix

然后注销系统。
回复

回到 “老旧版本支持”