当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 运行apt-get upgrade时,说安装xset出错
帖子发表于 : 2007-08-20 8:19 

注册: 2006-11-24 1:17
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
信息如下:
sudo apt-get upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
acpi-support: 依赖: xset 但是它还没有被安装
E: 不能满足依赖关系。不妨试一下 -f 选项。

然后我运行: sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 完成
将会安装下列额外的软件包:
xset
下列【新】软件包将被安装:
xset
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 163 个软件未被升级。
有 9 个软件包没有被完全安装或卸载。
需要下载 0B/19.9kB 的软件包。
解压缩后会消耗掉 81.9kB 的额外空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 87206 个文件和目录。)
正在解压缩 xset (从 .../xset_1%3a1.0.2-0ubuntu1_amd64.deb) ...
dpkg:处理 /var/cache/apt/archives/xset_1%3a1.0.2-0ubuntu1_amd64.deb (--unpack)时出错:
正试图覆盖“/usr/bin/xset”,它属于软件包 xbase-clients
在处理时有错误发生:
/var/cache/apt/archives/xset_1%3a1.0.2-0ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


请哪位大侠帮忙看看,谢谢。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-08-20 8:57 
头像

注册: 2007-01-15 17:15
帖子: 3766
送出感谢: 0 次
接收感谢: 0 次
什么版本? 如果是 gutsy ,,过几天再升级吧


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-08-20 8:59 

注册: 2006-11-24 1:17
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
是edgy,现在暂时不想升级到其它版本。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-08-20 9:08 
头像

注册: 2007-01-15 17:15
帖子: 3766
送出感谢: 0 次
接收感谢: 0 次
sorry 兄弟,我也搞不明白具体问题所在,也遇到过,,我一般都 apt-get autoremove ..或者 apt-get remove packagename ( xset ) ,然后再 update ,, 然后如果需要再装 ... 不是正常的方式方法,我是瞎折腾 : )


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-08-20 9:16 

注册: 2006-11-24 1:17
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
可以解决吗?


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-08-20 9:21 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
-f的强制安装,是坏习惯。少用。
用sudo aptitude install安装软件。

再不行,就换源。


_________________
● 鸣学


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译