当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 高手帮忙啊 东东卸载不了,新的也安装不上去
帖子发表于 : 2007-08-20 12:33 

注册: 2007-04-05 13:26
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get --purge remove xpdf --force-yes
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
软件包 xpdf 还未安装,因而不会被卸载
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 42 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B/765kB 的软件包。
解压缩后会消耗掉 0B 的额外空间。
选中了曾被取消选择的软件包 xpdf-reader。
(正在读取数据库 ... 系统当前总共安装有 117978 个文件和目录。)
正预备替换 xpdf-reader 3.01-9ubuntu3 (使用 .../xpdf-reader_3.01-9ubuntu3_i386.deb) ...
正在解压缩将用于更替的包文件 xpdf-reader ...
/bin/sh: Can't open update-menus
dpkg:警告 - 原先的 post-removal 脚本 退出时返回了错误号 2
dpkg - 现转而试用新软件包所带的脚本...
/bin/sh: Can't open update-menus
dpkg:处理 /var/cache/apt/archives/xpdf-reader_3.01-9ubuntu3_i386.deb (--unpack)时出错:
子进程·新的 post-removal 脚本·返回了错误号·2
/bin/sh: Can't open update-menus
dpkg: 作下列清理工作时发生错误:
子进程·post-removal script·返回了错误号·2
在处理时有错误发生:
/var/cache/apt/archives/xpdf-reader_3.01-9ubuntu3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-08-20 12:36 

注册: 2007-04-05 13:26
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
more /var/lib/dpkg/info/xpdf-reader.postinst
#!/bin/sh
set -e
# Automatically added by dh_installmime
if [ "$1" = "configure" ] && [ -x "`which update-mime 2>/dev/null`" ]; then
update-mime
fi
# End automatically added section
# Automatically added by dh_installmenu
if [ "$1" = "configure" ] && [ -x "`which update-menus 2>/dev/null`" ]; then
update-menus
fi
# End automatically added section
# Automatically added by dh_desktop
if [ "$1" = "configure" ] && which update-desktop-database >/dev/null 2>&1 ; then
update-desktop-database -q
fi
# End automatically added section


页首
 用户资料  
 
3 楼 
 文章标题 : # apt-get install xpdf
帖子发表于 : 2007-08-20 12:37 

注册: 2007-04-05 13:26
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
# apt-get install xpdf
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
下列【新】软件包将被安装:
xpdf
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 42 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B/766kB 的软件包。
解压缩后会消耗掉 36.9kB 的额外空间。
(正在读取数据库 ... 系统当前总共安装有 117978 个文件和目录。)
正预备替换 xpdf-reader 3.01-9ubuntu3 (使用 .../xpdf-reader_3.01-9ubuntu3_i386.deb) ...
正在解压缩将用于更替的包文件 xpdf-reader ...
/bin/sh: Can't open update-menus
dpkg:警告 - 原先的 post-removal 脚本 退出时返回了错误号 2
dpkg - 现转而试用新软件包所带的脚本...
/bin/sh: Can't open update-menus
dpkg:处理 /var/cache/apt/archives/xpdf-reader_3.01-9ubuntu3_i386.deb (--unpack)时出错:
子进程·新的 post-removal 脚本·返回了错误号·2
/bin/sh: Can't open update-menus
dpkg: 作下列清理工作时发生错误:
子进程·post-removal script·返回了错误号·2
选中了曾被取消选择的软件包 xpdf。
正在解压缩 xpdf (从 .../xpdf_3.01-9ubuntu3_all.deb) ...
在处理时有错误发生:
/var/cache/apt/archives/xpdf-reader_3.01-9ubuntu3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


页首
 用户资料  
 
4 楼 
 文章标题 : sudo dpkg -i --force-overwrite
帖子发表于 : 2007-08-20 12:47 

注册: 2007-04-05 13:26
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
dpkg -i --force-overwrite xpdf-reader_3.01-9ubuntu3_i386.deb
(正在读取数据库 ... 系统当前总共安装有 117981 个文件和目录。)
正预备替换 xpdf-reader 3.01-9ubuntu3 (使用 xpdf-reader_3.01-9ubuntu3_i386.deb) ...
正在解压缩将用于更替的包文件 xpdf-reader ...
/bin/sh: Can't open update-menus
dpkg:警告 - 原先的 post-removal 脚本 退出时返回了错误号 2
dpkg - 现转而试用新软件包所带的脚本...
/bin/sh: Can't open update-menus
dpkg:处理 xpdf-reader_3.01-9ubuntu3_i386.deb (--install)时出错:
子进程·新的 post-removal 脚本·返回了错误号·2
/bin/sh: Can't open update-menus
dpkg: 作下列清理工作时发生错误:
子进程·post-removal script·返回了错误号·2
在处理时有错误发生:
xpdf-reader_3.01-9ubuntu3_i386.deb


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-08-20 13:21 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
$ which update-menus
/usr/bin/update-menus


sudo apt-get install menu


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-08-21 18:54 

注册: 2007-04-05 13:26
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
oneleaf 写道:
$ which update-menus
/usr/bin/update-menus


sudo apt-get install menu

无效
于是
代码:
$ ls -l /usr/bin/update-menus
-rw-r--r-- 1 root root 129348 2006-11-14 01:52 /usr/bin/update-menus
$ sudo chmod 777 /usr/bin/update-menus

就全好了 :lol:


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 高手帮忙啊 东东卸载不了,新的也安装不上去
帖子发表于 : 2008-10-02 9:12 

注册: 2008-01-05 8:54
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
我的是这样,卸载时出现 E: virtualbox-ose: 子进程 post-removal script 返回了错误号 1
装了新软件不能用


_________________
AMD Sempron 3200+
Unika Radeon 1650GT DDR3 256m
Kinstone 1G667x2 Duel Channel
Seagate 7200.9 160G
Onda A69T(690G chip,ATI 1250 integrated)
Philips 190cw7


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译