请问我的6.10如何能升到2.6.20的内核?

为当前最终发行版之前的所有版本提供支持
duanius
帖子: 80
注册时间: 2006-10-01 23:59
送出感谢: 0
接收感谢: 0

请问我的6.10如何能升到2.6.20的内核?

#1

帖子 duanius » 2007-08-23 10:07

检查更新已经是最新的了 总是2.6.17 我的版本好像也不能从更新管理器里面升级到7.04 很头疼
请高手指点
上次由 duanius 在 2007-08-23 10:22,总共编辑 1 次。
janker2lonely
帖子: 557
注册时间: 2007-01-09 11:09
来自: 廣州
送出感谢: 0
接收感谢: 2 次

#2

帖子 janker2lonely » 2007-08-23 10:09

升级内核还不简单,自己下个源码,编译。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2007-08-23 10:11

直接版本升级就是。不有“更新管理器”? 支持检测到新版本,升级的。插入F/G的光盘,就可以了。
● 鸣学
duanius
帖子: 80
注册时间: 2006-10-01 23:59
送出感谢: 0
接收感谢: 0

#4

帖子 duanius » 2007-08-23 10:14

eexpress 写了:直接版本升级就是。不有“更新管理器”? 支持检测到新版本,升级的。插入F/G的光盘,就可以了。

我用更新管理器检查总是说我系统已经为最新 不知道是不是和源有关 我用的是cn99
F/G光盘是什么。。
duanius
帖子: 80
注册时间: 2006-10-01 23:59
送出感谢: 0
接收感谢: 0

#5

帖子 duanius » 2007-08-23 10:15

janker2lonely 写了:升级内核还不简单,自己下个源码,编译。

自己下代码编译要花不少时间吧?
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#6

帖子 skyx » 2007-08-23 10:19

6.10只能通过更新管理器升级到7.04,如果从7.04升级到7.10 ,在ubuntu 7.10正式版发布前,更新管理器应该也不会有升级到7.10的选项的。
http://forum.ubuntu.org.cn/viewtopic.ph ... 321#401321

ubuntu的升级,只能从当前版本升到下一个版,不可以跳过一个版本升级。

可以手动安装7.04 或7.10的内核, 但不推荐。
no security measure is worth anything if an attacker has physical access to the machine
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#7

帖子 eexpress » 2007-08-23 10:22

duanius 写了:
eexpress 写了:直接版本升级就是。不有“更新管理器”? 支持检测到新版本,升级的。插入F/G的光盘,就可以了。

我用更新管理器检查总是说我系统已经为最新 不知道是不是和源有关 我用的是cn99
F/G光盘是什么。。
用这管理器的时候,你要先多看论坛。源无关,要加光盘路径到源,apt-cdrom add这样的。然后F 就是feisty, G 就是guixxxx那个烂东西。你源里面没有新版本,当然说是最新的了啊。
● 鸣学
duanius
帖子: 80
注册时间: 2006-10-01 23:59
送出感谢: 0
接收感谢: 0

#8

帖子 duanius » 2007-08-23 10:24

skyx 写了:6.10只能通过更新管理器升级到7.04,如果从7.04升级到7.10 ,在ubuntu 7.10正式版发布前,更新管理器应该也不会有升级到7.10的选项的。
http://forum.ubuntu.org.cn/viewtopic.ph ... 321#401321

ubuntu的升级,只能从当前版本升到下一个版,不可以跳过一个版本升级。

可以手动安装7.04 或7.10的内核, 但不推荐。

不好意思 笔误笔误 我的意思是无法从更新管理器里面升到7.04 不是7.10.。。
我的版本在更新管理器里面连7.04都升不了
不过能不能升无所谓 关键是想升到2.6.20的内核。。
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#9

帖子 skyx » 2007-08-23 10:24

ubuntu的升级,只能从当前版本升到下一个版,不可以跳过一个版本升级。


比如说楼主现在用ubuntu 6.10 ,可以用 ubuntu 7.04 alternate cd 启动,启动后有个升级的选项的。

没有备份前不要跨版升级,如果升级不成功,很难回到老版ubuntu。
no security measure is worth anything if an attacker has physical access to the machine
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#10

帖子 skyx » 2007-08-23 10:26

duanius 写了:我的意思是无法从更新管理器里面升到7.04 不是7.10.。。
我的版本在更新管理器里面连7.04都升不了
不过能不能升无所谓 关键是想升到2.6.20的内核。。


我刚才给的url中你可以看到ubuntu 6.10 升级到ubuntu 7.04 的官方升级说明

基本意思是你要把当前6.10的升级全部升完后,更新管理器就会发现有新版可升。


在10楼,你可以仔细看下说明。
no security measure is worth anything if an attacker has physical access to the machine
duanius
帖子: 80
注册时间: 2006-10-01 23:59
送出感谢: 0
接收感谢: 0

#11

帖子 duanius » 2007-08-23 10:26

那在6.10下面能不能升到2.6.20 呢
不升级到7.04的情况下
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#12

帖子 skyx » 2007-08-23 10:27

duanius 写了:那在6.10下面能不能升到2.6.20 呢
不升级到7.04的情况下


我说过不推荐这样做。基实如果你用n卡,你把源改为7.04的后,重新从源中装一次n卡驱动,内核就变成7.04的了。

也可以直接手动下载内核deb安装


以上方法不推荐。


在IRC上问fidias ,让他教你编译内核, 编译内核方面,他在国内学术界是权威。
上次由 skyx 在 2007-08-23 10:29,总共编辑 1 次。
no security measure is worth anything if an attacker has physical access to the machine
janker2lonely
帖子: 557
注册时间: 2007-01-09 11:09
来自: 廣州
送出感谢: 0
接收感谢: 2 次

#13

帖子 janker2lonely » 2007-08-23 10:28

也不是很花时间,你可以睡觉前开始编译,等你睡醒就编译好了。
duanius
帖子: 80
注册时间: 2006-10-01 23:59
送出感谢: 0
接收感谢: 0

#14

帖子 duanius » 2007-08-23 10:28

可惜我的更新管理器总是提示已经最新 好像已经没的升了。。。
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#15

帖子 skyx » 2007-08-23 10:32

在IRC上问fidias ,让他教你编译内核, 编译内核方面,他在国内编译内核的学术界是权威。

最近他的《“一根杂毛都没有”的linux纯净系统》论文进入国际三大检索。根据国内惯例,进三大检索,凡影响因子很大的,就达到了教授职称的要求
no security measure is worth anything if an attacker has physical access to the machine
回复

回到 “老旧版本支持”