升级出了很多错误?

为当前最终发行版之前的所有版本提供支持
回复
oop277059367
帖子: 14
注册时间: 2007-07-18 22:46
送出感谢: 0
接收感谢: 0

升级出了很多错误?

#1

帖子 oop277059367 » 2007-08-23 10:12

原来编译过一次内核,体积太大了又删除了,之后升级就出错

dpkg:处理 initramfs-tools (--configure)时出错:
子进程 post-installation script 返回了错误号 1
dpkg:依赖关系问题使得 linux-image-2.6.22-10-generic 的配置工作不能继续:
linux-image-2.6.22-10-generic 依赖于 initramfs-tools (>= 0.36ubuntu6);然而:
软件包 initramfs-tools 还没有被配置。
dpkg:处理 linux-image-2.6.22-10-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 linux-ubuntu-modules-2.6.22-10-generic 的配置工作不能继续:
linux-ubuntu-modules-2.6.22-10-generic 依赖于 linux-image-2.6.22-10-generic;然而:
软件包 linux-image-2.6.22-10-generic 还没有被配置。
dpkg:处理 linux-ubuntu-modules-2.6.22-10-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 ubuntu-minimal 的配置工作不能继续:
ubuntu-minimal 依赖于 initramfs-tools;然而:
软件包 initramfs-tools 还没有被配置。
dpkg:处理 ubuntu-minimal (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 linux-image-generic 的配置工作不能继续:
linux-image-generic 依赖于 linux-image-2.6.22-10-generic;然而:
软件包 linux-image-2.6.22-10-generic 还没有被配置。
linux-image-generic 依赖于 linux-ubuntu-modules-2.6.22-10-generic;然而:
软件包 linux-ubuntu-modules-2.6.22-10-generic 还没有被配置。
dpkg:处理 linux-image-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 linux-restricted-modules-2.6.22-10-generic 的配置工作不能继续:
linux-restricted-modules-2.6.22-10-generic 依赖于 linux-image-2.6.22-10-generic;然而:
软件包 linux-image-2.6.22-10-generic 还没有被配置。
dpkg:处理 linux-restricted-modules-2.6.22-10-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 linux-restricted-modules-generic 的配置工作不能继续:
linux-restricted-modules-generic 依赖于 linux-restricted-modules-2.6.22-10-generic;然而:
软件包 linux-restricted-modules-2.6.22-10-generic 还没有被配置。
dpkg:处理 linux-restricted-modules-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 linux-generic 的配置工作不能继续:
linux-generic 依赖于 linux-image-generic;然而:
软件包 linux-image-generic 还没有被配置。
linux-generic 依赖于 linux-restricted-modules-generic;然而:
软件包 linux-restricted-modules-generic 还没有被配置。
dpkg:处理 linux-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 nvidia-glx 的配置工作不能继续:
nvidia-glx 依赖于 nvidia-kernel-1.0.9639;然而:
未曾安装软件包“nvidia-kernel-1.0.9639”。
软件包 linux-restricted-modules-2.6.22-10-generic 提供了 nvidia-kernel-1.0.9639,但是它还没有配置好。
dpkg:处理 nvidia-glx (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
initramfs-tools
linux-image-2.6.22-10-generic
linux-ubuntu-modules-2.6.22-10-generic
ubuntu-minimal
linux-image-generic
linux-restricted-modules-2.6.22-10-generic
linux-restricted-modules-generic
linux-generic
nvidia-glx
E: Sub-process /usr/bin/dpkg returned an error code (1)
oop@localhost:~$
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-08-23 10:17

dist-upgrade
版本升级。恢复到发行版本的范围。

没其他思路了。
● 鸣学
头像
aitilang
帖子: 1026
注册时间: 2007-04-28 21:38
送出感谢: 0
接收感谢: 0

#3

帖子 aitilang » 2007-08-23 10:38

吧那些出错的东西依次删掉。。
thinkpad x61 2G DDR no cdrom
--------------------------------------------
ABS学习中
sed学习中
awk学习中
perl学习中
新手描述不清,老手猜测不到,胡乱指挥一通,后果难以预料
oop277059367
帖子: 14
注册时间: 2007-07-18 22:46
送出感谢: 0
接收感谢: 0

#4

帖子 oop277059367 » 2007-08-23 21:23

多谢两位的帮忙

dist-upgrade我试过了,不行的

还有别的方法吗?现在都不能升级了

各位高手再帮出几个注意吧
回复

回到 “老旧版本支持”