添加cn99和Archive(欧洲)源出现如下错误,怎么解决阿?

为当前最终发行版之前的所有版本提供支持
回复
头像
qianwx
帖子: 730
注册时间: 2006-07-08 14:41
送出感谢: 0
接收感谢: 0

添加cn99和Archive(欧洲)源出现如下错误,怎么解决阿?

#1

帖子 qianwx » 2007-08-25 12:20

我手动添加了cn99和Archive(欧洲官方)的源之后,update之后就出现如下错误,请教如何解决呢???太奇怪了吧??但手动添加的这几个源注释之后却一切正常了。

代码: 全选

正在读取软件包列表... 有错误!
E: Dynamic MMap ran out of room
E: 处理 linux-headers-2.6.17-50-386 (NewVersion1)时出错
E: Problem with MergeList /var/lib/apt/lists/ubuntu.cn99.com_ubuntu_dists_edgy-proposed_main_binary-i386_Packages
E: 无法解析或打开软件包的列表或是状态文件。
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 BigSnake.NET » 2007-08-25 12:43

试试 sudo apt-get clean

/var空间不足了?
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
myneo
帖子: 14
注册时间: 2006-11-05 14:33
送出感谢: 0
接收感谢: 0

#3

帖子 myneo » 2007-08-25 12:44

网络通了吗?不会是网络没通吧!
头像
aitilang
帖子: 1026
注册时间: 2007-04-28 21:38
送出感谢: 0
接收感谢: 0

#4

帖子 aitilang » 2007-08-25 13:02

source.list里面的行太多了?
thinkpad x61 2G DDR no cdrom
--------------------------------------------
ABS学习中
sed学习中
awk学习中
perl学习中
新手描述不清,老手猜测不到,胡乱指挥一通,后果难以预料
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

#5

帖子 Element » 2007-08-25 17:55

deb http://ubuntu.cn99.com/ubuntu-cn/ feisty main restricted universe multiverse

把这行注释掉试试
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
头像
qianwx
帖子: 730
注册时间: 2006-07-08 14:41
送出感谢: 0
接收感谢: 0

#6

帖子 qianwx » 2007-08-26 22:55

回2楼的,我分区时就一个分区,挂载点是“/”根目录,且分区有40G,貌似没可能空间不够。。

回3楼的,如果网络不通,前面的部分就无法进行了,这个错误是最后下载列表时候出现的,且,当时更新时我还同时在浏览器中看网络小说呢,呵呵

回4楼,我虽然不知道source.list这个文件最多支持多少行,但我里面除了原始的一些以外,也就是compiz服务器的2行以及cn99等3个部分,应该不是行数太多吧?
我曾在添加好cn99等源之后,利用桌面环境中那个“软件源”图形界面打开看过,似乎添加的包括cn99的几个源都是ubuntu6.10版本的。。不要问我怎么知道的,你如果原版照搬cn99那近10行的源列表至source.list中再打开软件源界面,切换到第三方看看就知道了。希望那只是一个版本说明而不是真的只提供6.10版本更新吧。

回5楼,谢谢,我会再次试试看。。。事实上,我也曾怀疑是不是其中某一行有点问题。只是看更形时候的链接实在看不出倒地那一行有问题。另外,如上面说的,我也希望这几个源并不是只支持6.10版ubuntu更新。。
头像
jimhu
帖子: 1322
注册时间: 2006-01-25 22:29
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 jimhu » 2007-08-26 23:01

如果你用的不是6.10,那么你的源添加的是错误的,如果是7.04的话,源的最后应该是feisty结尾的,而不是edgy结尾的。
头像
qianwx
帖子: 730
注册时间: 2006-07-08 14:41
送出感谢: 0
接收感谢: 0

#8

帖子 qianwx » 2007-08-27 11:18

呵呵,难怪了,我说怎么有点奇怪。。。我确实是7.04版本的。。。总算又学了一招,原来ubuntu的源还有版本关系。。。晕哦~~~以前从没注意这些细节
IjustCome
帖子: 30
注册时间: 2006-10-08 17:53
送出感谢: 0
接收感谢: 0

#9

帖子 IjustCome » 2007-09-01 2:42

不一定, 我用6.06 LTScn99的原就会出现错误,可是换了中科大的源就没有问题
回复

回到 “老旧版本支持”