请问610版本是否支持LinuxThreads线程?

为当前最终发行版之前的所有版本提供支持
回复
whb610
帖子: 7
注册时间: 2007-08-26 0:26
送出感谢: 0
接收感谢: 0

请问610版本是否支持LinuxThreads线程?

#1

帖子 whb610 » 2007-08-26 1:00

我是新手,不太了解linux,想问一下610是否支持LinuxThreads线程,如果不支持,有什么方法可以解决。另外,可不可以在较高版本上(610)上编译低版本的内核。我想在低版本的ubuntu上会支持LinuxThreads线程,但是我的机器太新了,能装上ubuntu的最低版本就是610,低版本找不到驱动,请大家不吝赐教,给我扫扫盲,我的机器配置:主板:技嘉965p-s3 内存2G cpu intelE6600 硬盘 串口320G企业级 显卡 影驰7600GS :lol:
头像
xhy
帖子: 3916
注册时间: 2005-12-28 1:16
系统: Ubuntu 12.10 X64
来自: 火星
送出感谢: 1 次
接收感谢: 0

#2

帖子 xhy » 2007-08-26 1:40

一些应用要求特定版本的内核
可以编译任意版本的内核 交叉编译环境还是比较好建立的

高版本的linux难道不支持thread?
目前负债150多万
whb610
帖子: 7
注册时间: 2007-08-26 0:26
送出感谢: 0
接收感谢: 0

谢谢回答

#3

帖子 whb610 » 2007-08-26 9:15

是啊,稍微高一点的版本只支持nptl线程了,但是我的软件需要LinuxThreads线程,nptl线程不行。现在的2.6内核都不行,2.4内核的还可以,610版本下可以编译2.4内核吧?可以的话能提供较快的链接吗?谢谢,对了,还有一个问题,重新编译后是不是需要安装阿?如果需要重新安装我担心还是安装不上。
头像
xhy
帖子: 3916
注册时间: 2005-12-28 1:16
系统: Ubuntu 12.10 X64
来自: 火星
送出感谢: 1 次
接收感谢: 0

#4

帖子 xhy » 2007-08-26 9:34

2.4的内核还是装个redhat 9吧
目前负债150多万
whb610
帖子: 7
注册时间: 2007-08-26 0:26
送出感谢: 0
接收感谢: 0

redhat9装不上

#5

帖子 whb610 » 2007-08-26 12:06

redhat9装不上
whb610
帖子: 7
注册时间: 2007-08-26 0:26
送出感谢: 0
接收感谢: 0

redhat9装不上

#6

帖子 whb610 » 2007-08-26 12:06

redhat9装不上
whb610
帖子: 7
注册时间: 2007-08-26 0:26
送出感谢: 0
接收感谢: 0

哪位达人能帮帮忙,救命!!

#7

帖子 whb610 » 2007-08-27 10:34

再次感谢
IjustCome
帖子: 30
注册时间: 2006-10-08 17:53
送出感谢: 0
接收感谢: 0

#8

帖子 IjustCome » 2007-09-01 2:49

radhat9 是不认sata硬盘的,因该是装不上。(但是你可以改BIOS选项)

Linux的内核是和GCC的版本有很大的关系的,我估计在高版本的宿主机上编译的内核

不大行吧,不过你可以安装低版本的GCC。
头像
patrickhe
帖子: 681
注册时间: 2005-07-21 19:13
来自: Peking, China
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 patrickhe » 2007-09-03 15:49

在重新编译内核的时候,选上 LinuxThreads 线程库就可以了。编译成功之后,在 Grub 里面加上相关信息就可以用支持 LinuxThreads 的内核引导。

不过,比较困惑地问问,是自己新开发的程序吗,如果是的话,为什么需要用 LinuxThreads 而不是 NPTL 呢?
头像
xjflyttp
帖子: 281
注册时间: 2006-10-18 0:36
来自: Core
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 xjflyttp » 2007-09-03 23:34

又一个扣肉~~~不如来跑boinc吧~~~hoho~~
T60p/T7600/2G/WD1600BJKT/BT/AR5008/V5200/15' QXGA
回复

回到 “老旧版本支持”