线程问题

为当前最终发行版之前的所有版本提供支持
回复
whb610
帖子: 7
注册时间: 2007-08-26 0:26
送出感谢: 0
接收感谢: 0

线程问题

#1

帖子 whb610 » 2007-08-26 21:27

想请教一个问题,如何能让ubuntu610支持linuxthreads线程呢?我的软件必须用linuxthreads线程,nptl不行,但是早期版本的linux在我的机器上装不上,谢谢大家的帮忙
janker2lonely
帖子: 557
注册时间: 2007-01-09 11:09
来自: 廣州
送出感谢: 0
接收感谢: 2 次

#2

帖子 janker2lonely » 2007-08-26 21:48

:shock:
头像
xhy
帖子: 3916
注册时间: 2005-12-28 1:16
系统: Ubuntu 12.10 X64
来自: 火星
送出感谢: 1 次
接收感谢: 0

#3

帖子 xhy » 2007-08-27 0:49

把老内核的线程库移植进来?
这个工作量有点大

搜了一下 早在2000年的时候就有人遇到跟你一样的问题了
这个问题就像要在Vista下面使用实模式一样

老版本的不可能安装不上去
如果你是sata硬盘 稍微麻烦一点
搜索 redhat9 sata install
可能9还是不够老 那就试试7

最好还是使用NPTL
不然做出来的东西 只能在自己一台机器上用
目前负债150多万
whb610
帖子: 7
注册时间: 2007-08-26 0:26
送出感谢: 0
接收感谢: 0

感谢回答

#4

帖子 whb610 » 2007-08-27 10:31

请问如何把老的线程库移植进来?或者告诉我哪里找到这方面的资料也行,这对于我来讲是最好的,这样也许我可以把双核都利用起来。我实在不知道该怎么把老版本的linux装上去。串口硬盘时报告没有驱动,用并口硬盘时也报告没有驱动,主板上的IDE口是主板厂商自己扩展出来的,不知道是怎么回事。或者我直接编译一个低版本内核?有高版本向低版本更新可以吗?还有一个问题,内核为2.4.1的ubuntu是哪个版本,可以告诉一下在那里下载吗?感谢达人回答
回复

回到 “老旧版本支持”