求救在线等。。。!!!关于卸载compiz-gnome安装出错

为当前最终发行版之前的所有版本提供支持
回复
billcools
帖子: 9
注册时间: 2007-08-04 10:55
送出感谢: 0
接收感谢: 0

求救在线等。。。!!!关于卸载compiz-gnome安装出错

#1

帖子 billcools » 2007-09-01 1:12

请问,我刚装compiz-gnome是出了问题。。现在用sudo apt-get -f install和sudo apt-get remove都删除不掉,老是报错,应该怎么修复呢?
sudo apt-get -f install 错误信息:
正在解压缩 compiz-gnome (从 .../compiz-gnome_1%3a0.5.5~git20070828+3v1ubuntu0_i386.deb) ...dpkg:处理 /var/cache/apt/archives/compiz-gnome_1%3a0.5.5~git20070828+3v1ubuntu0_i386.deb (--unpack)时出错: 正试图覆盖“/usr/lib/compiz/libgconf.so”,它属于软件包 compiz-plugins在处理时有错误发生: /var/cache/apt/archives/compiz-gnome_1%3a0.5.5~git20070828+3v1ubuntu0_i386.debE: Sub-process /usr/bin/dpkg returned an error code (1)
billcools
帖子: 9
注册时间: 2007-08-04 10:55
送出感谢: 0
接收感谢: 0

#2

帖子 billcools » 2007-09-01 1:20

找到解决方法了。

用dpkg -r把所有依赖包都卸载掉再重新安装
epf00mmr
帖子: 133
注册时间: 2007-09-14 16:06
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 epf00mmr » 2007-09-16 1:33

* 定位到系统--系统管理--新利得软件包管理器,打开后在左边栏找到"已损坏",卸载损坏的安装包(实际就是删除原有的compiz),退出.
* 下载安装#问题1中提到的compiz core,compiz plugin和libdecoration三个文件.
* 重新执行sudo apt-get install compiz compiz-gnome,或者如果你愿意可以直接依次下载上面的所有deb包安装(个人推荐).
lb_bn
帖子: 1261
注册时间: 2007-02-25 16:56
送出感谢: 0
接收感谢: 0

#4

帖子 lb_bn » 2007-09-16 10:38

直接新立得多好。。。
回复

回到 “老旧版本支持”