更新服务提示错误软件索引被破坏

为当前最终发行版之前的所有版本提供支持
回复
头像
lxf1597
帖子: 81
注册时间: 2006-12-29 11:03
送出感谢: 0
接收感谢: 0
联系:

更新服务提示错误软件索引被破坏

#1

帖子 lxf1597 » 2007-09-01 14:27

提示说软件索引被破坏,要求运行sudo apt-get install -f 下面是运行结果。。。。。能帮我看看怎么能解决么?一部分软件无法更新升级了

代码: 全选

crucifix@crucifix-desktop:~$ sudo apt-get install -f
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
读取状态信息... 完成             
正在更正依赖关系... 完成
将会安装下列额外的软件包:
  compiz-gnome
下列的软件包将被升级:
  compiz-gnome
共升级了 1 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 3 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B/162kB 的软件包。
解压缩后会消耗掉 893kB 的额外空间。
您希望继续执行吗?[Y/n]y
【警告】:下列的软件包不能通过验证!
  compiz-gnome
不经验证就安装这些软件包么?[y/N] y
(正在读取数据库 ... 系统当前总共安装有 124334 个文件和目录。)
正预备替换 compiz-gnome 1:0.3.6-1ubuntu13 (使用 .../compiz-gnome_1%3a0.5.5~git20070824+3v1ubuntu0_i386.deb) ...
正在解压缩将用于更替的包文件 compiz-gnome ...
dpkg:处理 /var/cache/apt/archives/compiz-gnome_1%3a0.5.5~git20070824+3v1ubuntu0_i386.deb (--unpack)时出错:
 正试图覆盖“/usr/lib/compiz/libgconf.so”,它属于软件包 compiz-plugins
在处理时有错误发生:
 /var/cache/apt/archives/compiz-gnome_1%3a0.5.5~git20070824+3v1ubuntu0_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
crucifix@crucifix-desktop:~$ 
sudo apt-get update用过了,但是问题依旧

查了下,compiz-gnome 是1:0.3.6-lubuntu13版本的,compiz是1:0.5.5-git20070824版本的,这是刚刚系统自动升级更新的文件,是不是这里存在问题?其他安装的COMPIZ系列的东西都是1:0.3.6-lubuntu13版本,当时更新了compiz 和库libdecoration0,现在的compiz和库都是1:0.5.5-git20070824
是不是这些冲突了?
怎么解决呢?
linux是开源的,是个性的。
但是永远都不是彰显你自己不凡的资本!
能让linux在所有PC上出现并且像WIN一样易用的人
永远值得所有linuxer标榜膜拜!
回复

回到 “老旧版本支持”