[问题]gtk装不上,qt也不行,怎么解决?

为当前最终发行版之前的所有版本提供支持
回复
头像
anod221
帖子: 76
注册时间: 2007-04-10 18:36
来自: 西安
送出感谢: 0
接收感谢: 0
联系:

[问题]gtk装不上,qt也不行,怎么解决?

#1

帖子 anod221 » 2007-09-01 19:42

这是装gtk的情况

sudo apt-get install gnome-core-devel
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
gnome-core-devel: 依赖: libatspi-dev (>= 1.6.6) 但是它将不会被安装
依赖: libeel2-dev (>= 2.14.3) 但是它将不会被安装
依赖: libgnomeprintui2.2-dev (>= 2.12.1) 但是它将不会被安装
依赖: libgnomeprint2.2-dev (>= 2.12.1) 但是它将不会被安装
依赖: libnautilus-extension-dev (>= 2.12.2) 但是它将不会被安装
依赖: libgail-dev (>= 1.8.9) 但是它将不会被安装
依赖: libgtk2.0-dev (>= 2.8.20) 但是它将不会被安装
依赖: libpanel-applet2-dev (>= 2.14.3) 但是它将不会被安装
依赖: libpango1.0-dev (>= 1.12.3) 但是它将不会被安装
依赖: libglade2-dev (>= 1:2.6.0) 但是它将不会被安装
依赖: libgnomeui-dev (>= 2.12.0) 但是它将不会被安装
依赖: librsvg2-dev (>= 2.14.4) 但是它将不会被安装
依赖: libgtksourceview-dev (>= 1.6.2) 但是它将不会被安装
E: 无法安装的软件包
qt也差不多,怎么解决呢??
头像
magicsky
帖子: 225
注册时间: 2007-03-30 9:46
送出感谢: 1 次
接收感谢: 0

#2

帖子 magicsky » 2007-09-02 15:54

自己下源码编译吧,呵呵
在国外,众多程序员为了理想而夜以继日;
而在国内,程序员在为填饱自己和家人的肚子而埋头苦干。
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 zhan » 2007-09-02 16:48

首先,检查 你的 源。我们推荐 http://wiki.ubuntu.org.cn/快速设置指南/FeistyFawn 上面提供的源。

其次,安装 gtk ....似乎你的理解有点问题。
如果是要做 gtk 开发的话,那需要的可能是 libgtk2.0-dev 这样的包,以及一些 libgtkxxx 的包,和你安装的 那个包没有什么关系。而且,你安装的全是开发包,不是有特别的应用的话,没有什么意义。

其三 gnome != gtk。
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
头像
anod221
帖子: 76
注册时间: 2007-04-10 18:36
来自: 西安
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 anod221 » 2007-09-02 21:06

其实我是要用于开发的,我用的是cn99的源,我更改过其它的源还是有问题。用libgtk2.0-dev也不能安装,出现这样子的提示
libgtk2.0-dev: 依赖: libpango1.0-dev (>= 1.12) 但是它将不会被安装
依赖: libcairo2-dev (>= 1.2.0) 但是它将不会被安装
E: 无法安装的软件包
头像
anod221
帖子: 76
注册时间: 2007-04-10 18:36
来自: 西安
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 anod221 » 2007-09-03 23:08

下了源代码来编译了qt,所有的部件都有了,不过qmake -project的时候却一直卡在那里不动,输入按键也能够出现相应的输入,这是怎么一回事呢??
头像
anod221
帖子: 76
注册时间: 2007-04-10 18:36
来自: 西安
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 anod221 » 2007-09-04 13:08

已经搞好了,我想应该是因为那个目录下面有太多的文件夹了,qmake找不着依赖关系吧,把那个main.cpp放到一个单独的文件夹里面qmake就没有问题了
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#7

帖子 stlxv » 2007-09-04 20:46

qt开发包的话装kdesdk就行了,gtk就忘了装哪个了,总之用新立得软件包管理器搜一下要什么软件就有什么软件
PHP是最好的语言!不服来战!
回复

回到 “老旧版本支持”