当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决]郁闷~无法升级到7.04了....
帖子发表于 : 2007-09-02 17:42 

注册: 2007-03-16 23:31
帖子: 55
地址: China
送出感谢: 0 次
接收感谢: 0 次
好不容易下定决心把6.10升级到7.04,down了n小时的更新包后在安装时却遇到如下 错误
引用:
sudo apt-get upgrade
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
belocs-locales-bin: 依赖: libc6 (>= 2.5-0ubuntu1) 但是 2.4-1ubuntu12.3 已经安装了
libc6-dev: 依赖: libc6 (= 2.5-0ubuntu14) 但是 2.4-1ubuntu12.3 已经安装了
libc6-pic: 依赖: libc6 (= 2.5-0ubuntu14) 但是 2.4-1ubuntu12.3 已经安装了
libc6-prof: 依赖: libc6 (= 2.5-0ubuntu14) 但是 2.4-1ubuntu12.3 已经安装了
perl: 依赖: perl-base (= 5.8.8-7build1) 但是 5.8.8-6 已经安装了
依赖: libc6 (>= 2.5-0ubuntu1) 但是 2.4-1ubuntu12.3 已经安装了
perl-suid: 依赖: libc6 (>= 2.5-0ubuntu1) 但是 2.4-1ubuntu12.3 已经安装了
依赖: libperl5.8 (= 5.8.8-7build1) 但是 5.8.8-6 已经安装了
E: 不能满足依赖关系。不妨试一下 -f 选项。
$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在更正依赖关系... 完成
The following packages were automatically installed and are no longer required:
libgoffice-gtk-0-3 libgoffice-0-common anthy libots0 libaiksaurusgtk-1.2-0c2a abiword-common
libaiksaurus-1.2-0c2a scim-hangul gnumeric-common tidy libtidy-0.99-0 libt1-5 libaiksaurus-1.2-data
libgdome2-0 libgdome2-cpp-smart0c2a libanthy0 scim-anthy libgtkmathview0c2a abiword-plugins
使用 'apt-get autoremove' 来删除它们。
将会安装下列额外的软件包:
libc6 libperl5.8 perl-base
建议安装的软件包:
glibc-doc
下列的软件包将被升级:
libc6 libperl5.8 perl-base
共升级了 3 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 1330 个软件未被升级。
有 9 个软件包没有被完全安装或卸载。
需要下载 0B/5397kB 的软件包。
解压缩后会消耗掉 65.5kB 的额外空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 190054 个文件和目录。)
正预备替换 libc6 2.4-1ubuntu12.3 (使用 .../libc6_2.5-0ubuntu14_i386.deb) ...
Matching libraries: /usr/lib/libc.so.6

A copy of glibc was found in an unexpected directory.
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library and try again.
Please check: https://launchpad.net/bugs/81125
Matching libraries: /usr/X11R6/lib/libc.so.6

Another copy of the C library was found via /etc/ld.so.conf.
It is not safe to upgrade the C library in this situation;
please remove the directory from /etc/ld.so.conf and try again.
Please check: https://launchpad.net/bugs/81125
正在解压缩将用于更替的包文件 libc6 ...
dpkg:处理 /var/cache/apt/archives/libc6_2.5-0ubuntu14_i386.deb (--unpack)时出错:
dpkg:警告 - 原先的 post-removal 脚本 被信号(段错误)终止了

dpkg: 作下列清理工作时发生错误:
子进程 pre-installation script 被信号(段错误)终止了
在处理时有错误发生:
/var/cache/apt/archives/libc6_2.5-0ubuntu14_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

由于初学ubuntu不久,实在没有解决这种问题的经验,拜请各位赐教
;;
刚才把7.04装好了,看来问题在这里
引用:
A copy of glibc was found in an unexpected directory.
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library and try again.
Please check: https://launchpad.net/bugs/81125
Matching libraries: /usr/X11R6/lib/libc.so.6

Another copy of the C library was found via /etc/ld.so.conf.
It is not safe to upgrade the C library in this situation;
please remove the directory from /etc/ld.so.conf and try again.
Please check: https://launchpad.net/bugs/81125


在/usr/X11R6/lib存在libc文件引起冲突,删掉后就能升级了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译