HowTO-如何降级

为当前最终发行版之前的所有版本提供支持
回复
头像
freeflying
论坛版主
帖子: 521
注册时间: 2005-03-26 9:38
送出感谢: 0
接收感谢: 0

HowTO-如何降级

#1

帖子 freeflying » 2005-12-14 10:32

breezy -->hoary
1 设定源

代码: 全选

deb http://archive.ubuntu.com/ubuntu hoary main restricted universe multiverse 

deb http://archive.ubuntu.com/ubuntu breezy main restricted universe multiverse
2 设定 pinning

代码: 全选

sudo gedit /etc/apt/preferences
加上如下内容

代码: 全选

       Package: *
        Pin: release a=hoary
        Pin-Priority: 1001

        Package: *
        Pin: release a=breezy
        Pin-Priority: 60
3 降级

代码: 全选

sudo apt-get update

代码: 全选

sudo apt-get dist-upgrade
注:有一定的危险,可能会把你系统搞的一团糟,慎用!
图片
shenmue
帖子: 33
注册时间: 2005-10-13 10:06
送出感谢: 0
接收感谢: 0

#2

帖子 shenmue » 2005-12-14 11:22

这个方法是不是对Debian也同样适用?
shenmue
帖子: 33
注册时间: 2005-10-13 10:06
送出感谢: 0
接收感谢: 0

#3

帖子 shenmue » 2005-12-14 13:17

降级时发生错误

代码: 全选

在处理时有错误发生:
 /var/cache/apt/archives/gnome-terminal_2.10.0-0ubuntu2_i386.deb
 /var/cache/apt/archives/gtk2-engines-clearlooks_0.5-0ubuntu1_i386.deb
 /var/cache/apt/archives/ubuntu-artwork_0.2.24-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
头像
dongmh
帖子: 715
注册时间: 2005-06-21 20:24
来自: 甘肃
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 dongmh » 2005-12-14 15:35

小白问下 为何要降级?
ubuntu 6.06
我是初学者 大家多多关照
回复

回到 “老旧版本支持”