如何从breezy升级到dapper?

为当前最终发行版之前的所有版本提供支持
回复
atfa
帖子: 88
注册时间: 2005-08-22 11:13
送出感谢: 0
接收感谢: 0

如何从breezy升级到dapper?

#1

帖子 atfa » 2005-12-15 16:26

我设置了下面的源

代码: 全选

deb http://ubuntu.cn99.com/ubuntu dapper main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu dapper-updates main restricted
提示必须用apt-get -f install解决冲突

看到apt-get -f install的信息:

代码: 全选

The following packages will be REMOVED:
  beagle bug-buddy contact-lookup-applet deskbar-applet eog evince evolution evolution-exchange
  evolution-plugins evolution-webcal file-roller firefox-gnome-support gcalctool gconf-editor gdesklets
  gdesklets-data gdm gedit gnome-about gnome-app-install gnome-applets gnome-applets-data gnome-btdownload
  gnome-control-center gnome-cups-manager gnome-media gnome-netstatus-applet gnome-panel gnome-pilot
  gnome-pilot-conduits gnome-session gnome-spell gnome-system-monitor gnome-system-tools gnome-terminal
  gnome-utils gnome-volume-manager gnomebaker gnomemeeting gthumb gtkhtml3.8 gucharmap hal-device-manager
  hwdb-client libedataserverui1.2-6 libeel2-2 libevolution-cil libexchange-storage1.2-0 libgnome-desktop-2
  libgnome2-perl libgnome2.0-cil libgnomecupsui1.0-1 libgnomeui-0 libgtkhtml3.8-15 libgucharmap4
  libpanel-applet2-0 nautilus nautilus-cd-burner nautilus-sendto python-gnome2 python-gnome2-extras
  python2.4-gnome2 python2.4-gnome2-extras serpentine sound-juicer stardict totem-xine tsclient update-manager
  update-notifier vim-gnome vino yelp

我的天哪,这谁还敢升级?

不知道应该怎么操作才好?
头像
oneleaf
论坛管理员
帖子: 10238
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 107 次

#2

帖子 oneleaf » 2005-12-15 16:48

试试: sudo apt-get dist-upgrade
herohao
帖子: 18
注册时间: 2005-12-08 14:30
送出感谢: 0
接收感谢: 0

#3

帖子 herohao » 2005-12-22 17:05

出现这样的情况怎么办呢
是因为源里包不全的原因吗
E: 无法更正缺少的软件包

W: 未能取回 ftp://linux.xjtu.edu.cn/mirror/ubuntu/u ... 2_i386.deb
无法获取文件,服务器响应道“/mirror/ubuntu/ubuntu/pool/universe/t/totem/totem-xine-firefox-plugin_1.3.0-0ubuntu2_i386.deb: No such file or directory ”


W: 未能取回 ftp://linux.xjtu.edu.cn/mirror/ubuntu/u ... 2_i386.deb
无法获取文件,服务器响应道“/mirror/ubuntu/ubuntu/pool/universe/t/totem/totem-xine_1.3.0-0ubuntu2_i386.deb: No such file or directory ”


W: 未能取回 ftp://linux.xjtu.edu.cn/mirror/ubuntu/u ... -1_all.deb
无法获取文件,服务器响应道“/mirror/ubuntu/ubuntu/pool/universe/s/scim-tables/scim-tables-zh_0.5.5-1_all.deb: No such file or directory ”


W: 未能取回 ftp://linux.xjtu.edu.cn/mirror/ubuntu/u ... 1_i386.deb
无法获取文件,服务器响应道“/mirror/ubuntu/ubuntu/pool/universe/s/scim-tables/scim-modules-table_0.5.5-1_i386.deb: No such file or directory ”


W: 未能取回 ftp://linux.xjtu.edu.cn/mirror/ubuntu/u ... -2_all.deb
无法获取文件,服务器响应道“/mirror/ubuntu/ubuntu/pool/restricted/l/linux-restricted-modules-2.6.15/linux-restricted-modules-common_2.6.15.3-2_all.deb: No such file or directory ”


W: 未能取回 ftp://linux.xjtu.edu.cn/mirror/ubuntu/u ... 2_i386.deb
无法获取文件,服务器响应道“/mirror/ubuntu/ubuntu/pool/restricted/l/linux-restricted-modules-2.6.15/linux-restricted-modules-2.6.15-9-386_2.6.15.3-2_i386.deb: No such file or directory ”


W: 未能取回 ftp://linux.xjtu.edu.cn/mirror/ubuntu/u ... 2_i386.deb
无法获取文件,服务器响应道“/mirror/ubuntu/ubuntu/pool/restricted/l/linux-restricted-modules-2.6.15/linux-restricted-modules-2.6.15-9-686_2.6.15.3-2_i386.deb: No such file or directory ”
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#4

帖子 catinsnow » 2005-12-25 1:20

最好用官方的源,其它的更新太慢.

代码: 全选

deb http://archive.ubuntu.com/ubuntu dapper-updates main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu dapper-security main restricted universe multiverse

deb http://archive.ubuntu.com/ubuntu dapper main restricted universe multiverse
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
slxslxslx
帖子: 21
注册时间: 2005-12-25 9:05
送出感谢: 0
接收感谢: 0

#5

帖子 slxslxslx » 2005-12-25 21:01

catinsnow 写了:最好用官方的源,其它的更新太慢.

代码: 全选

deb http://archive.ubuntu.com/ubuntu dapper-updates main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu dapper-security main restricted universe multiverse

deb http://archive.ubuntu.com/ubuntu dapper main restricted universe multiverse
这几个源我用上海电信的adsl速度很不理想,我加上了cn99和archive.ubuntu.org.cn的连接以提升速度,结果升级出问题了,Xserver被我升级的无法正确运行了,因为是linux菜鸟,只好拿出之前在windows上面准备的用acronis true image做得镜像备份还原了。
建议对linux还不熟悉,机器上面又有windows的用户也弄一个acronis true image弄个备份先,速度很快的(备份和还原都飞快)。本人现在就在还原好的系统上面发帖呢,一切正常。
头像
BaByChU
帖子: 20
注册时间: 2005-07-05 10:13
送出感谢: 0
接收感谢: 1 次

#6

帖子 BaByChU » 2005-12-28 14:55

最好不要从breezy基础上升级dapper
要用dapper最好是下载dapper的cd
或者从breezy server基础上升级安装

dapper很不稳定
很多程序经常crash
出现包依赖关系错误的时候最好运行
apt-get --purge remove 包名
彻底删除软件后重新安装
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#7

帖子 eexpress » 2005-12-28 17:24

怎么这么多想做小白的?不懂
● 鸣学
回复

回到 “老旧版本支持”