[问题]升級系統的指令是upgrade么?

为当前最终发行版之前的所有版本提供支持
回复
头像
xjflyttp
帖子: 281
注册时间: 2006-10-18 0:36
来自: Core
送出感谢: 0
接收感谢: 0
联系:

[问题]升級系統的指令是upgrade么?

#1

帖子 xjflyttp » 2007-09-08 0:59

以前看到的是
apt-get dist-upgrade

apt-get upgrade

后來在linuxsir上面看到說新版的ubuntu不推薦使用dist-upgrade.....
那是不是就apt-get upgrade足夠了?
T60p/T7600/2G/WD1600BJKT/BT/AR5008/V5200/15' QXGA
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#2

帖子 jimmin » 2007-09-08 1:23

upgrade 普通升级(软件升级)
dist-upgrade 核心升级(包括系统内核的升级)
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#3

帖子 jimmin » 2007-09-08 1:24

新版的ubuntu不推荐使用dist-upgrade在哪里看到的?难道命令变了?
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#4

帖子 jimmin » 2007-09-08 1:28

代码: 全选

$ apt-get -h
apt 0.6.46.4ubuntu10 for linux i386 ,编译于 Mar 14 2007 17:43:24
用法: apt-get [选项] 命令
       apt-get [选项] install|remove 包甲 [包乙 ...]
       apt-get [选项] source 包甲 [包乙 ...]

apt-get 提供了一个用于下载和安装软件包的简易命令行界面。
最常用命令是 update 和 install。

命令:
   update - 下载更新软件包列表信息
   upgrade - 进行一次升级
   install - 安装新的软件包(注:包名是 libc6 而非 libc6.deb)
   remove - 卸载软件包
   source - 下载源码包文件
   build-dep - 为源码包配置所需的构建依赖关系
   dist-upgrade - 发布版升级,见 apt-get(8)
   dselect-upgrade - 根据 dselect的选择来进行升级
   clean - 删除所有已下载的包文件
   autoclean - 删除老版本的已下载的包文件
   check - 核对以确认系统的依赖关系的完整性
选项:
  -h  本帮助文档。
  -q  让输出可作为日志 - 不显示进度
  -qq 除了错误外,什么都不输出
  -d  仅仅下载 - 【不】安装或解开包文件
  -s  不作实际操作。只是依次模拟执行命令
  -y  对所有询问都作肯定的回答,同时不作任何提示
  -f  当没有通过完整性测试时,程序仍试图继续执行
  -m  当有包文件无法找到时,程序仍试图继续执行
  -u  显示已升级的软件包列表
  -b  在下载完源码包后,编译生成相应的软件包
  -V  显示详尽的版本号
  -c=? 读取指定配置文件
  -o=? 设置任意指定的配置选项,例如 -o dir::cache=/tmp
请查阅 apt-get(8)、sources.list(5) 和 apt.conf(5)的参考手册
以获取更多信息和选项。
                       本 APT 有着超级牛力。
头像
xjflyttp
帖子: 281
注册时间: 2006-10-18 0:36
来自: Core
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 xjflyttp » 2007-09-08 1:49

jimmin 写了:新版的ubuntu不推荐使用dist-upgrade在哪里看到的?难道命令变了?
上次在linuxsir一个帖子里面看到.......还是超级坚定说的 ~~无语了
T60p/T7600/2G/WD1600BJKT/BT/AR5008/V5200/15' QXGA
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#6

帖子 jimmin » 2007-09-08 2:00

经你这么一说我也有点怀疑了,把help仔细看了看也可能是

upgrade 普通升级(包括内核的升级)
dist-upgrade 发布版升级(比如改源后7.04升级到7.10)

不过我平时升级都用dist-upgrade,因为方便也不会有遗漏,而且我第一次看到别人apt命令的解释就是2楼的。
下次试试用upgrade会不会升级核心就知道怎么回事了,让事实说话吧! :D
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#7

帖子 zhuqin_83 » 2007-09-08 2:02

一般用dist-upgrade,不会有遗漏,upgrade会少更新不少东西。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
xhy
帖子: 3916
注册时间: 2005-12-28 1:16
系统: Ubuntu 12.10 X64
来自: 火星
送出感谢: 1 次
接收感谢: 0

#8

帖子 xhy » 2007-09-08 9:50

dist-upgrade常引起问题倒是真的

ubuntu发生过好几次dist-upgrade后无法引导的事件
目前负债150多万
头像
xjflyttp
帖子: 281
注册时间: 2006-10-18 0:36
来自: Core
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 xjflyttp » 2007-09-08 10:12

xhy 写了:dist-upgrade常引起问题倒是真的

ubuntu发生过好几次dist-upgrade后无法引导的事件
我以前6.10得时候就试过用dist-upgrade以后就引导到一个#下面 不知道为什么。。上次又看到那个帖子~都不敢再dist了`~~
T60p/T7600/2G/WD1600BJKT/BT/AR5008/V5200/15' QXGA
回复

回到 “老旧版本支持”