sudo apt-get install php5-gd --没装成--已经解决

为当前最终发行版之前的所有版本提供支持
回复
sqlfm
帖子: 356
注册时间: 2007-02-15 6:26
送出感谢: 0
接收感谢: 1 次

sudo apt-get install php5-gd --没装成--已经解决

#1

帖子 sqlfm » 2007-09-08 7:14

$ sudo apt-get install php5-gd
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
php5-gd: 依赖: php5-common (= 5.2.1-0ubuntu1) 但是 5.2.1-0ubuntu1.2 正要被安装
E: 无法安装的软件包

-----
注:我的办公室的装成了。不知如何办呢?谢谢。
上次由 sqlfm 在 2007-09-08 14:18,总共编辑 1 次。
2007:琉璃地,旃檀林。心心作。念念是。
sqlfm
帖子: 356
注册时间: 2007-02-15 6:26
送出感谢: 0
接收感谢: 1 次

#2

帖子 sqlfm » 2007-09-08 13:44

deleted
上次由 sqlfm 在 2007-09-08 14:17,总共编辑 1 次。
2007:琉璃地,旃檀林。心心作。念念是。
onlyiknow
帖子: 527
注册时间: 2007-05-06 2:18
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 onlyiknow » 2007-09-08 14:00

看来是软件依赖的问题

你试着在新立得那搜索安装吧,应该可以自动安装依赖
sqlfm
帖子: 356
注册时间: 2007-02-15 6:26
送出感谢: 0
接收感谢: 1 次

#4

帖子 sqlfm » 2007-09-08 14:17

谢谢--解决了。

原因:source.list被我弄坏了,现在好了。
2007:琉璃地,旃檀林。心心作。念念是。
回复

回到 “老旧版本支持”