关于软件安装中出现的问题(已解决)

为当前最终发行版之前的所有版本提供支持
回复
头像
ericlam
帖子: 340
注册时间: 2007-05-06 20:42
来自: Matrix
送出感谢: 0
接收感谢: 0
联系:

关于软件安装中出现的问题(已解决)

#1

帖子 ericlam » 2007-09-09 9:35

新出了virtulabox 1.5,于是我把我原来的1.4删除,重新安装1.5,我是下载DEB包的,点击安装后,一直提示安装中,已超过了正常安装的时间,于是我重启了系统,然后再重新安装,但就提示了以下这个方框,而实际上,我并没有找开其它的新立得,请问是何原因[/img]
附件
Screenshot-gdebi-gtk.png
Screenshot-gdebi-gtk.png (7.28 KiB) 查看 637 次
上次由 ericlam 在 2007-09-09 15:44,总共编辑 1 次。
我是ubuntu的小白鼠,只有往前跑,才不会闷死。
我的小白鼠 blog

MSN:ericlam@live.com
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#2

帖子 leeaman » 2007-09-09 9:42

virtulabox似乎要点开那个安装界面左下面的小箭头在里面同意那个版权协议吧,然后才安装的
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
头像
ericlam
帖子: 340
注册时间: 2007-05-06 20:42
来自: Matrix
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 ericlam » 2007-09-09 10:43

在“软件包安装”界面上并没有LS所说的小箭头,我觉得是系统自身的问题,因为我原来安装1.4是正常的,现在要重新安装1.4也是提示上面的界面
我是ubuntu的小白鼠,只有往前跑,才不会闷死。
我的小白鼠 blog

MSN:ericlam@live.com
头像
ericlam
帖子: 340
注册时间: 2007-05-06 20:42
来自: Matrix
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 ericlam » 2007-09-09 10:49

我刚才打开新立得,出现如下的界面,一点击就退出了新立得
附件
Screenshot-synaptic.png
Screenshot-synaptic.png (9.31 KiB) 查看 635 次
我是ubuntu的小白鼠,只有往前跑,才不会闷死。
我的小白鼠 blog

MSN:ericlam@live.com
头像
ericlam
帖子: 340
注册时间: 2007-05-06 20:42
来自: Matrix
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 ericlam » 2007-09-09 13:37

刚才重新检查了一下,记起来,刚才在删除vbox1.4时,我手动删除了在/home的一个带. 的目录(“.virtualbox")的目录,我想这是最主要的原因,现在怎么去解决呢?
我是ubuntu的小白鼠,只有往前跑,才不会闷死。
我的小白鼠 blog

MSN:ericlam@live.com
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#6

帖子 skyx » 2007-09-09 13:40

有时候设定了自动升级,也可能会出现同时运行两个软件包的情况(一个自动,一个是手动打开的),一般快速解决可以重启x .最好关掉升级提示和自动升级。
no security measure is worth anything if an attacker has physical access to the machine
头像
ericlam
帖子: 340
注册时间: 2007-05-06 20:42
来自: Matrix
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 ericlam » 2007-09-09 13:42

skyx 写了:有时候设定了自动升级,也可能会出现同时运行两个软件包的情况(一个自动,一个是手动打开的),一般快速解决可以重启x .最好关掉升级提示和自动升级。
重启后,也是出现同样的情况,我想是我误删了.vartualbox目录而造成的,不知怎么解决
我是ubuntu的小白鼠,只有往前跑,才不会闷死。
我的小白鼠 blog

MSN:ericlam@live.com
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#8

帖子 skyx » 2007-09-09 13:46

ericlam 写了:
skyx 写了:有时候设定了自动升级,也可能会出现同时运行两个软件包的情况(一个自动,一个是手动打开的),一般快速解决可以重启x .最好关掉升级提示和自动升级。
重启后,也是出现同样的情况,我想是我误删了.vartualbox目录而造成的,不知怎么解决
.vartualbox 这个目录删掉不应该有什么关系,那自动升级是比较讨厌。我安装完ubuntu第一件事就是去掉它。
no security measure is worth anything if an attacker has physical access to the machine
头像
ericlam
帖子: 340
注册时间: 2007-05-06 20:42
来自: Matrix
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 ericlam » 2007-09-09 13:47

skyx 写了:
ericlam 写了:
skyx 写了:有时候设定了自动升级,也可能会出现同时运行两个软件包的情况(一个自动,一个是手动打开的),一般快速解决可以重启x .最好关掉升级提示和自动升级。
重启后,也是出现同样的情况,我想是我误删了.vartualbox目录而造成的,不知怎么解决
.vartualbox 这个目录删掉不应该有什么关系
是的,我就是删了这个目录,我记得我删除时,里面还有文件,现在错误提示好像也提提示找不到相应的文件
我是ubuntu的小白鼠,只有往前跑,才不会闷死。
我的小白鼠 blog

MSN:ericlam@live.com
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#10

帖子 leeaman » 2007-09-09 15:05

代码: 全选

sudo apt-get install -f
or

代码: 全选

sudo dpkg --configure -a
看看再说吧,删那个目录没有什么影响的,新装的自己会建立的
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
头像
ericlam
帖子: 340
注册时间: 2007-05-06 20:42
来自: Matrix
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 ericlam » 2007-09-09 15:43

刚才在论坛找了下,发现有个也是和我一样的情况,其实就是删除virtualbox 1.4时强行重启,而造成有文件留下系统,这样在要安装1.5时,系统认为有软件正在安装,所以一直提示有新立得正常运行,解决方式:
因为我是下载DEB包的,我下载了virtualbox1.5,然后在终端里 cd到我放下载文件的那个目录,然后输入以下

代码: 全选

 sudo dpkg -i virtualbox.deb 
这样系统会强行安装virtualbox文件, 这里需注意一点,在安装时,弹出的对话框的左下解有个“终端”字样的,要按下去,会下拉出来一个命令行格式的窗口,里面有选择需要你去选择,按“tab”键选择,这一点要特别注意,否则你等半天,那个进度条也在那边走来走去,你以为软件安装出现问题,这个也是我第一次安装时没去注意的,所以我就强行关闭,而造成后来的异常。
我是ubuntu的小白鼠,只有往前跑,才不会闷死。
我的小白鼠 blog

MSN:ericlam@live.com
头像
chattan
论坛版主
帖子: 3922
注册时间: 2007-07-11 20:59
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 chattan » 2007-09-09 17:17

我安装virtualbox的时候,那个正在安装的滚动条不停的在滚动,此时一定要点终端前面的小三角,因为安装程序有问题需要你确定,不要以为是因为安装出了 问题,如果此时强行退出安装 会出现很多麻烦: 新立得用不了,升级管理器用不了
apt-get 用不了
此时需要用sudo dpkg --remove --force-remove-reinstreq virtualbox
然后重新安装
头像
ericlam
帖子: 340
注册时间: 2007-05-06 20:42
来自: Matrix
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 ericlam » 2007-09-09 17:48

chattan 写了:我安装virtualbox的时候,那个正在安装的滚动条不停的在滚动,此时一定要点终端前面的小三角,因为安装程序有问题需要你确定,不要以为是因为安装出了 问题,如果此时强行退出安装 会出现很多麻烦: 新立得用不了,升级管理器用不了
apt-get 用不了
此时需要用sudo dpkg --remove --force-remove-reinstreq virtualbox
然后重新安装
sudo dpkg --remove --force-remove-reinstreq 文件名
是不是固定的格式?
我是ubuntu的小白鼠,只有往前跑,才不会闷死。
我的小白鼠 blog

MSN:ericlam@live.com
回复

回到 “老旧版本支持”