[教学]完全定制安装Ubuntu 7.04

为当前最终发行版之前的所有版本提供支持
回复
once375ml
帖子: 57
注册时间: 2006-02-24 16:56
送出感谢: 0
接收感谢: 0

[教学]完全定制安装Ubuntu 7.04

#1

帖子 once375ml » 2007-09-10 9:52

无论是Alternate Feisty CD还是Desktop CD安装完成后总是有很多东西是我们不需要的,何不像fedora一样按自己的需要定制ubuntu的安装

首先你需要安装一个Command Line System,如果你不明白这是什么,你还是不要往下看了,默认完全安装吧,等你对linux有了充分的了解后在回来看这篇文章

Command Line System 安装完成后进入你新的命令行系统并执行以下指令(目的是减少你输密码的次数):sudo su -
然后塞进去你的Feisty Alternative CD安装盘,这样可以减少很多盘上已有的包的下载,执行apt-get update (不建议此时apt-get dist-upgrade,可以等所有的都完成后在图形界面下再更新也不迟)
如果你的处理器支持自动变频和节能,那么你最好安装上powernowd,对AMD和Intel都适用,虽然当初是为AMD设计的,强烈建议笔记本安装:apt-get install powernowd
安装基本图形界面:apt-get install xorg gdm ssh
你可以用/etc/init.d/gdm start 测试是否成功.一般是肯定成功的,所以你可以不用试了,然后再用’Ctrl + Alt + F1′.切换出去,因为我们还有很多东西要继续
安装Gnome桌面:apt-get install gnome-session gnome-menus gnome-panel metacity nautilus
如果你想完全使用Gnome作为桌面的话你还需要安装:apt-get install gnome-applets gnome-control-center gnome-volume-manager libsmbclient gnome-screensaver menu network-manager-gnome gnome-utils gnome-system-tools gnome-netstatus-applet gnome-nettool libgnomevfs2-extra
必须安装的软件:apt-get install gnome-terminal gedit firefox
安装系统主题等:apt-get install ubuntu-artwork ubuntu-sounds human-theme usplash-theme-ubuntu,如果你想用gnome自带的那么:apt-get install gnome-themes tango-icon-theme tango-icon-theme-extras,个人觉得还是ubuntu的好看点,二选一就可以了
安装图形化工具,让你管理软件和驱动更容易apt-get install gnome-app-install update-manager restricted-manager
3D桌面:apt-get install beryl-manager emerald-themes,完成后’System Tools’下的’Beryl Manager’自己设置吧
视频音频:apt-get install gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-ugly gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly-multiverse
其他软件:apt-get install gnomebaker eog gaim gcalctool gimp gthumb file-roller ekiga evince mozilla-thunderbird openoffice.org openoffice.org-gnome rhythmbox totem-xine totem-mozilla xsane,我只建议安装gcalctool file-roller evince mozilla-thunderbird rhythmbox totem-xine totem-mozilla,分别是计算器,解压缩,PDF浏览,邮件客户端,音乐播放器,视频播放器及firefox视频插件;如果你是刻录机则还要gnomebaker,扫描仪:xsane……
受限驱动:apt-get install ubuntu-restricted-extras
打印:apt-get install cupsys cupsys-bsd cupsys-client cupsys-common cupsys-driver-gutenprint foo2zjs foomatic-db foomatic-db-engine foomatic-db-hpijs foomatic-filters gimp-print gnome-cups-manager,非办公环境就不需要了
好了,一个完全属于你的系统诞生了,重启吧,对了,如果你的系统登陆登出都没有声音是因为你忘了apt-get install esound

补充:中文支持 apt-get install language-pack-zh



好色男@ubuntu 7.04

已发送至LinuxToy LDCN
附件
180px-Ubuntu-7_04-feisty.png
上次由 once375ml 在 2007-09-10 10:06,总共编辑 1 次。
头像
tkey
帖子: 13
注册时间: 2007-05-14 21:09
送出感谢: 0
接收感谢: 0

#2

帖子 tkey » 2007-09-10 9:57

Command Line System 怎么装都不写 BS
once375ml
帖子: 57
注册时间: 2006-02-24 16:56
送出感谢: 0
接收感谢: 0

#3

帖子 once375ml » 2007-09-10 10:05

tkey 写了:Command Line System 怎么装都不写 BS
如果这个都要我教的话我不建议你如此安装一个新系统,因为如果中途除了问题你根本就不知道什么是什么

最简安装要一定的基础的,至少知道每条命令的意思
头像
内存不足
论坛版主
帖子: 3277
注册时间: 2005-08-18 18:43
送出感谢: 0
接收感谢: 1 次
联系:

#4

帖子 内存不足 » 2007-09-10 10:29

哦 给高手 高高手看的....... 飘过
໌→ iCookie Gtk Theme
໌→DropPlusBluetheme
กรัก กรัก`菠萝
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#5

帖子 leeaman » 2007-09-10 11:20

没有什么大用,除了省一点点的白菜价的硬盘空间,对系统多那么一点点的了解,由于没有完全安装,使用时会有这里那里的一点点毛病
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
once375ml
帖子: 57
注册时间: 2006-02-24 16:56
送出感谢: 0
接收感谢: 0

#6

帖子 once375ml » 2007-09-10 11:31

leeaman 写了:没有什么大用,除了省一点点的白菜价的硬盘空间,对系统多那么一点点的了解,由于没有完全安装,使用时会有这里那里的一点点毛病
一般不会


对于对系统有强迫症和偏执狂患者——像我,我决不允许系统有我不要的软件,缺少我要用的软件 :D
wkt
帖子: 849
注册时间: 2006-09-07 22:51
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 wkt » 2007-09-10 11:36

leeaman 写了:没有什么大用,除了省一点点的白菜价的硬盘空间,对系统多那么一点点的了解,由于没有完全安装,使用时会有这里那里的一点点毛病
哪来毛病?
不是有apt-get 吗?
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#8

帖子 leeaman » 2007-09-10 11:47

once375ml 写了:
leeaman 写了:没有什么大用,除了省一点点的白菜价的硬盘空间,对系统多那么一点点的了解,由于没有完全安装,使用时会有这里那里的一点点毛病
一般不会


对于对系统有强迫症和偏执狂患者——像我,我决不允许系统有我不要的软件,缺少我要用的软件 :D
哦,lz强人,失敬,速度快一点我可以考虑一下
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#9

帖子 leeaman » 2007-09-10 11:49

wkt 写了:
leeaman 写了:没有什么大用,除了省一点点的白菜价的硬盘空间,对系统多那么一点点的了解,由于没有完全安装,使用时会有这里那里的一点点毛病
哪来毛病?
不是有apt-get 吗?
主要是哪个文件关联还是默认全部安装的样子,有时候会莫名其妙的提示少东西,你自己安装的软件运行时
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
wkt
帖子: 849
注册时间: 2006-09-07 22:51
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 wkt » 2007-09-10 12:41

leeaman 写了:
wkt 写了:
leeaman 写了:没有什么大用,除了省一点点的白菜价的硬盘空间,对系统多那么一点点的了解,由于没有完全安装,使用时会有这里那里的一点点毛病
哪来毛病?
不是有apt-get 吗?
主要是哪个文件关联还是默认全部安装的样子,有时候会莫名其妙的提示少东西,你自己安装的软件运行时
这个我没有见过
once375ml
帖子: 57
注册时间: 2006-02-24 16:56
送出感谢: 0
接收感谢: 0

#11

帖子 once375ml » 2007-09-10 17:19

leeaman 写了:
wkt 写了:
leeaman 写了:没有什么大用,除了省一点点的白菜价的硬盘空间,对系统多那么一点点的了解,由于没有完全安装,使用时会有这里那里的一点点毛病
哪来毛病?
不是有apt-get 吗?
主要是哪个文件关联还是默认全部安装的样子,有时候会莫名其妙的提示少东西,你自己安装的软件运行时


这个问题一般出现在自己编译安装软件的时候出现,有时aptget的依赖都不够新 要自己去找依赖的源码自己编译
然后你缺我,我缺他,张三缺李四,能把人烦死

不过这种情况就是你全部安装也会出现的阿
vsscj
帖子: 16
注册时间: 2007-06-04 17:33
送出感谢: 0
接收感谢: 0

#12

帖子 vsscj » 2007-09-11 15:14

路过
头像
xhy
帖子: 3916
注册时间: 2005-12-28 1:16
系统: Ubuntu 12.10 X64
来自: 火星
送出感谢: 1 次
接收感谢: 0

#13

帖子 xhy » 2007-09-11 17:28

lz装的东西不少了

估计省不了硬盘空间
目前负债150多万
回复

回到 “老旧版本支持”