新立德软件包管理器出错

为当前最终发行版之前的所有版本提供支持
回复
lonewolflu
帖子: 5
注册时间: 2007-08-10 13:06
送出感谢: 0
接收感谢: 0

新立德软件包管理器出错

#1

帖子 lonewolflu » 2007-09-10 17:01

新立德软件包管理器里面自带的pgadmin3版本太旧,而且我在使用过程当中发现了一些bug,于是想升级我的pgadmin3。
我在http://www.pgadmin.org/download/ubuntu.php?lang=zh_CN上找到了新版的下载页面,按照页面所介绍的操作一下,但没有下载成功。以下是该网页内容:

pgAdmin III packages are available for the Ubuntu dapper and feisty distributions.
Before you try to install

The archive files are signed with a dedicated GPG Key. Before trying to install the pgAdmin III packages, you should add the corresponding public key to your apt keyring this way (as root):
wget -q -O - http://www.pgadmin.org/pgp/archive_key_ ... ubuntu.gpg | apt-key add -

Once the key added, you need to choose a mirror from the list of PostgreSQL mirrors and configure your sources.list. Click one of the flags, and copy the URL you are redirected to. On each mirror, the packages are located in: /pgadmin3/release/ubuntu

Then follow the specific instructions below.
Ubuntu Dapper configuration

Choose your mirror as mentioned above and edit /etc/apt/sources.list file and add the following line:
deb [MIRROR URL]/pgadmin3/release/ubuntu dapper pgadmin
Ubuntu Feisty configuration

Choose your mirror as mentioned above and edit /etc/apt/sources.list file and add the following line:
deb [MIRROR URL]/pgadmin3/release/ubuntu feisty pgadmin

例如,在法国,你可以试一下:
deb ftp://ftp2.fr.postgresql.org/postgresql ... ase/ubuntu feisty pgadmin

Please, note that you additionally need to ENABLE THE UNIVERSE COMPONENT as wxWidgets2.8 is available from universe only at the moment. To do so, check the Ubuntu documentation or at least try to launch the update-manager configuration from the System/Administration Gnome menu.
Proceed to installation

Simply use Synaptic to install pgAdmin III as you would do with any other package or run the following command from the command prompt:
sudo apt-get update
sudo apt-get install pgadmin3

然后问题出来了:
我之后使用新立德软件包管理器,无论安装卸载那个软件包,都会出错。报错的是:
dpkg:警告 - 原先的 pre-removal 脚本 退出时返回了错误号 1
请问我该如何解决这个问题?
我估计是我之前的这个操作造成的:
wget -q -O - http://www.pgadmin.org/pgp/archive_key_ ... ubuntu.gpg | apt-key add -
回复

回到 “老旧版本支持”