[问题]编译安装飞鸽问题

为当前最终发行版之前的所有版本提供支持
回复
wangsen
帖子: 346
注册时间: 2006-11-04 22:16
送出感谢: 0
接收感谢: 0

[问题]编译安装飞鸽问题

#1

帖子 wangsen » 2007-09-11 9:03

安装编译环境的时候出现:
sudo apt-get install libxml-parser-perl libgnomeui-dev libpanel-applet2-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
libxml-parser-perl 已经是最新的版本了。
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libgnomeui-dev: 依赖: libgtk2.0-dev (>= 2.9.0) 但是它将不会被安装
依赖: libgnomecanvas2-dev (>= 2.6.0) 但是它将不会被安装
依赖: libbonoboui2-dev (>= 2.13.1) 但是它将不会被安装
依赖: libpango1.0-dev (>= 1.1.2) 但是它将不会被安装
E: 无法安装的软件包
是什么原因呀?也尝试安装它依赖的包。可是那些被依赖的包还有其他依赖的包包!晕。
头像
magicsky
帖子: 225
注册时间: 2007-03-30 9:46
送出感谢: 1 次
接收感谢: 0

#2

帖子 magicsky » 2007-09-11 19:19

apt-get -f install试试
在国外,众多程序员为了理想而夜以继日;
而在国内,程序员在为填饱自己和家人的肚子而埋头苦干。
头像
aca
帖子: 129
注册时间: 2007-04-22 13:23
送出感谢: 0
接收感谢: 0

#3

帖子 aca » 2007-09-11 20:18

你这哪是编译.....
回复

回到 “老旧版本支持”