当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]进入iceWM界面后怎么自动运行软件(没有“会话”)(已解决)
帖子发表于 : 2007-09-12 18:49 

注册: 2007-04-18 15:12
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
请教大家:
我想进入iceWM界面后就自动运行软件,谁知道怎么办?
声明下:
1、没有会话功能;
2、类似于QQ之类的软件;

谢谢大家了!


最后由 hecant 编辑于 2007-09-13 17:01,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-09-12 19:09 
头像

注册: 2007-06-02 14:56
帖子: 547
送出感谢: 0 次
接收感谢: 0 次
1.在~/.icewm/目录 下创建一个 启动脚本文件startup
代码:
vi ~/.icewm/startup


2.文件内容类似:
引用:
#!/bin/sh
your-command-here &
... &

这里的每个程序都必须在后台执行。

3.然后为这个文件加上执行权限:
代码:
chmod u+x ~/.icewm/startup

完成。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-09-13 15:12 

注册: 2007-04-18 15:12
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
谢谢你的回答!

我之前也看过关于icewm的帖子,
Ubuntu下安装使用iceWM:http://www.80x86.cn/article.asp?id=554
icewm介绍:http://www.linuxfans.org/bbs/viewthread.php?action=printable&tid=49597
IceWM FAQ(常見問題解答)及 Howto(快速指引):http://b2d.tnc.edu.tw/icewm-doc/faq/

1、但是我在~/.icewm/startup编写脚本:


引用:
#!/bin/sh
oclock &

重启根本没效果。
2、我在~/.xsession加入代码也没用

引用:
oclok &


请问哪个高手能帮我实现下,就像windows下一样进入界面后能自动启动类似QQ的软件(就是启动后我可以操作,不是后台),谢谢了!


最后由 hecant 编辑于 2007-09-13 15:23,总共编辑了 1 次

页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-09-13 15:14 
头像

注册: 2007-06-02 14:56
帖子: 547
送出感谢: 0 次
接收感谢: 0 次
你的startup文件位置不对啊

#!/bin/sh
oclok &

怎么看!&象全角的啊? oclok又是什么 :(


最后由 ofewiofewo 编辑于 2007-09-13 15:40,总共编辑了 1 次

页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-09-13 15:23 

注册: 2007-04-18 15:12
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
sorry,刚才写错了,我的是在~/.icewm/startup!
:oops:


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-09-13 15:42 
头像

注册: 2007-06-02 14:56
帖子: 547
送出感谢: 0 次
接收感谢: 0 次
你仔细检查一下吧,我这里是可以的


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-09-13 15:48 

注册: 2007-04-18 15:12
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
恩,我在~/.icewm/startup编写代码:
引用:
#!/bin/sh
x-terminal-emulator &

我在terminal终端中写入:
引用:
sudo ~/.icewm/startup

就会启动Terminal,但是重启后不自动启动,实现郁闷!

ofewiofewo老兄,你还有其他方法没,或是看看我出了什么错?!!
万分感谢!


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-09-13 16:00 

注册: 2007-04-18 15:12
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
很有可能是权限问题!
我是在vmware下运行的,而且是用gdm实现自动登录的,不是root权限!
ofewiofewo老兄,你觉得有可能是权限问题吗?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-09-13 16:29 

注册: 2007-04-18 15:12
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
ofewiofewo老兄,谢谢你啊!
我的问题已经解决了,是我在编写~/.icewm/startup脚本时错误:
引用:
是oclock&
不是oclock &


:D


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译