求助!摄像头驱动问题!

为当前最终发行版之前的所有版本提供支持
回复
sleeping2003
帖子: 1
注册时间: 2007-09-12 23:39
送出感谢: 0
接收感谢: 0

求助!摄像头驱动问题!

#1

帖子 sleeping2003 » 2007-09-12 23:40

我在fedaro 6下 下载了一个摄像头驱动:gspcav1-20070508.tar.gz,解压缩后就make,然后出现以下问题:

[root@localhost gspcav1]# make
make -C /lib/modules/`uname -r`/build SUBDIRS=/gspcav1 CC=cc modules
make[1]: Entering directory `/usr/src/linux-2.6.15.i586'
CC [M] /gspcav1/gspca_core.o
/gspcav1/gspca_core.c:4201: 错误:初始值设定项里有未知的字段 ‘owner’
/gspcav1/gspca_core.c:4201: 警告:从不兼容的指针类型初始化
make[2]: *** [/gspcav1/gspca_core.o] 错误 1
make[1]: *** [_module_/gspcav1] 错误 2
make[1]: Leaving directory `/usr/src/linux-2.6.15.i586'
make: *** [default] 错误 2

请教高手,该如何解决。
万分万分感谢!
潇洒的怪兽
帖子: 89
注册时间: 2007-06-18 11:33
送出感谢: 0
接收感谢: 0

#2

帖子 潇洒的怪兽 » 2007-09-13 0:28

你内核咩版本的
回复

回到 “老旧版本支持”