dpkg was interrupted, you must manually run 'dpkg --configu

为当前最终发行版之前的所有版本提供支持
回复
epf00mmr
帖子: 133
注册时间: 2007-09-14 16:06
送出感谢: 0
接收感谢: 0
联系:

dpkg was interrupted, you must manually run 'dpkg --configu

#1

帖子 epf00mmr » 2007-09-15 9:07

我执行命令,为老不是出来这个提示,我英语不好。不太认识,请高手指点。谢谢。
PhoenixJ
帖子: 1488
注册时间: 2007-08-09 3:33
系统: Windows 12.04
送出感谢: 2 次
接收感谢: 1 次

#2

帖子 PhoenixJ » 2007-09-15 14:24

那就按照提示运行一下 sudo dpkg --configure好了。
epf00mmr
帖子: 133
注册时间: 2007-09-14 16:06
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 epf00mmr » 2007-09-16 0:07

非常感谢,问题解决了,呵呵。真是高手。
饭前洗手
帖子: 26
注册时间: 2007-05-30 9:43
送出感谢: 0
接收感谢: 0

#4

帖子 饭前洗手 » 2007-11-14 8:27

我也遇到了类似的问题,
不过看了解决方法后,也弄好了,
真的是非常感谢2楼的高手,
谢谢!!
yiwenjun
帖子: 9
注册时间: 2009-07-24 22:42
送出感谢: 0
接收感谢: 0

Re: dpkg was interrupted, you must manually run 'dpkg --configu

#5

帖子 yiwenjun » 2009-08-08 23:18

我的问题是出现在执行下列命令时
sudo apt-get install sun-java6-jdk
因为中间给中断了
上面问题解决了,但是我再去执行sudo apt-get install sun-java6-jdk就出现下面情况
yiwenjun@yiwenjun-laptop:~$ sudo apt-get install sun-java6-jdk
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
sun-java6-jdk: 依赖: sun-java6-bin (= 6-14-0ubuntu1.8.10) 但是它将不会被安装
sun-java6-jre: 依赖: sun-java6-bin (= 6-14-0ubuntu1.8.10) 但是它将不会被安装 或
ia32-sun-java6-bin (= 6-14-0ubuntu1.8.10) 但却无法安装它
推荐: gsfonts-x11 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
yiwenjun@yiwenjun-laptop:~$

请问是怎么回事,谢谢
runmouse
帖子: 5
注册时间: 2009-10-28 21:38
送出感谢: 0
接收感谢: 0

Re: dpkg was interrupted, you must manually run 'dpkg --configu

#6

帖子 runmouse » 2009-11-01 22:14

我也遇到了这种情况,哪位大牛指导一下

yiwenjun 写了:我的问题是出现在执行下列命令时
sudo apt-get install sun-java6-jdk
因为中间给中断了
上面问题解决了,但是我再去执行sudo apt-get install sun-java6-jdk就出现下面情况
yiwenjun@yiwenjun-laptop:~$ sudo apt-get install sun-java6-jdk
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
sun-java6-jdk: 依赖: sun-java6-bin (= 6-14-0ubuntu1.8.10) 但是它将不会被安装
sun-java6-jre: 依赖: sun-java6-bin (= 6-14-0ubuntu1.8.10) 但是它将不会被安装 或
ia32-sun-java6-bin (= 6-14-0ubuntu1.8.10) 但却无法安装它
推荐: gsfonts-x11 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
yiwenjun@yiwenjun-laptop:~$

请问是怎么回事,谢谢
回复

回到 “老旧版本支持”