dpkg: 该操作需要超级用户权限

为当前最终发行版之前的所有版本提供支持
回复
chris_ju
帖子: 2
注册时间: 2007-09-15 17:14
送出感谢: 0
接收感谢: 0

dpkg: 该操作需要超级用户权限

#1

帖子 chris_ju » 2007-09-15 17:21

今天安装完Ubuntu后,还没高兴完就来个下马威。我用更新管理器更新的时候更新了一般,因为感觉更新太慢就关掉了更新窗口,结果出现以下提示,更新完全更新不了,不能安装任何软件:
chris@chris-pc:~$ sudo apt-get install sun-java6-jre
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

按上边所说,键入dpkg --configure -a出现:dpkg: 该操作需要超级用户权限。可我已经是用管理员用户登录,请教各位如果操作,谢谢!
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#2

帖子 leeaman » 2007-09-15 17:33

chris@chris-pc:~$ sudo apt-get install sun-java6-jre
触类傍通

代码: 全选

sudo dpkg --configure -a
你安装是建立的用户是比root低级的帐号,可以通过命令前加sudo前缀临时获得root权限
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
回复

回到 “老旧版本支持”