[问题]NTFS-3g的问题(不知道该发哪个版)[已解决]

为当前最终发行版之前的所有版本提供支持
回复
sanz
帖子: 1009
注册时间: 2006-09-29 5:11
送出感谢: 11 次
接收感谢: 5 次

[问题]NTFS-3g的问题(不知道该发哪个版)[已解决]

#1

帖子 sanz » 2007-09-15 23:09

fstab我设置为
/dev/sda3 /media/windows_D ntfs-3g defaults,umask=0,locale=LC_CTYPE=zh_CN.UTF-8 0 0

每次启动后ntfs分区自动挂载,但是其中中文文件、目录无法显示。umount后再重新mount,显示、修改都正常,就是mount命令行有错误提示:
-----------------------------------------------------------------------------------------------------------------------
WARNING: Couldn't set locale to 'LC_CTYPE=zh_CN.UTF-8' thus some file names may not
be correct or visible. Please see the potential solution at
http://www.ntfs-3g.org/support.html#locale
-------------------------------------------------------------------------------------------------------------------------

很困惑,为什么自动挂载就不行,手动挂载就可以呢?但为什么有这个错误呢?

我的locale:
----------------------------
LANG=en_US.UTF-8
LANGUAGE=en_US:en
LC_CTYPE=zh_CN.UTF-8
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
-------------------------------------------------
上次由 sanz 在 2007-09-16 15:29,总共编辑 1 次。
Dell D620 -> Asus U44SG
Dapper->Edgy->Feisty->Gutsy->Hardy->Karmic->Lucid -> Oneric -> Precise->Trusty
Python+JS
头像
cnshzj007
帖子: 685
注册时间: 2006-05-24 21:38
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 cnshzj007 » 2007-09-16 0:43

bond007@ubuntu007:~$ locale
LANG=zh_CN.UTF-8
LC_CTYPE="zh_CN.UTF-8"
LC_NUMERIC="zh_CN.UTF-8"
LC_TIME="zh_CN.UTF-8"
LC_COLLATE="zh_CN.UTF-8"
LC_MONETARY="zh_CN.UTF-8"
LC_MESSAGES="zh_CN.UTF-8"
LC_PAPER="zh_CN.UTF-8"
LC_NAME="zh_CN.UTF-8"
LC_ADDRESS="zh_CN.UTF-8"
LC_TELEPHONE="zh_CN.UTF-8"
LC_MEASUREMENT="zh_CN.UTF-8"
LC_IDENTIFICATION="zh_CN.UTF-8"
LC_ALL=
bond007@ubuntu007:~$
我只是一个ARCH的FANS,来自RH和UBUNTU的滋润!
sanz
帖子: 1009
注册时间: 2006-09-29 5:11
送出感谢: 11 次
接收感谢: 5 次

#3

帖子 sanz » 2007-09-16 9:15

楼上的什么意思?我的locale 就是这样的啊!我也知道你的locale是纯中文的。但是你没有回答我的问题。难道要我为了这个把locale彻底改掉?
Dell D620 -> Asus U44SG
Dapper->Edgy->Feisty->Gutsy->Hardy->Karmic->Lucid -> Oneric -> Precise->Trusty
Python+JS
头像
freedom8971
帖子: 182
注册时间: 2007-08-05 2:50
送出感谢: 0
接收感谢: 0

#4

帖子 freedom8971 » 2007-09-16 12:43

嗯.....我的也是每次开机必须手动

代码: 全选

mount -a

自动也不可以
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#5

帖子 leeaman » 2007-09-16 12:45

/dev/sda3 /media/windows_D ntfs-3g defaults,umask=0,locale=LC_CTYPE=zh_CN.UTF-8 0 0

红字不要
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
sanz
帖子: 1009
注册时间: 2006-09-29 5:11
送出感谢: 11 次
接收感谢: 5 次

#6

帖子 sanz » 2007-09-16 15:28

楼上正解!谢谢。
不过我是在网上搜的配置方法,不知道为什么会这样。手动怎么没有问题呢?奇怪
Dell D620 -> Asus U44SG
Dapper->Edgy->Feisty->Gutsy->Hardy->Karmic->Lucid -> Oneric -> Precise->Trusty
Python+JS
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#7

帖子 leeaman » 2007-09-16 15:33

这个参数的问题我也不知道,反正你那样就是不对,装一个ntfs-config方便很多的,什么都可以不理了
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
回复

回到 “老旧版本支持”