当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]有关依赖的一个奇怪的问题。
帖子发表于 : 2007-09-16 0:48 

注册: 2007-05-09 16:52
帖子: 633
送出感谢: 1
接收感谢: 0 次
我上网搜vbox的安装方法,结果看到这么一篇:
但是我在安装第2步骤的时候却提示:
lanpeng@lanpeng-laptop:~$ sudo apt-get install libxalan110 libxerces27
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
virtualbox: 依赖: libqt3-mt (>= 3:3.3.8really3.3.7) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。


请问是什么原因阿?





安装 VirtualBox

在 Ubuntu 中安装 VirtualBox 可以按照以下的步骤进行操作:

1. 下载安装包。建议下载 Deb 包,方便直接在 Ubuntu 中安装。你需要根据所使用的 Ubuntu 版本来有选择地进行下载。如果是 Dapper 版,就下载适用于 Dapper 的安装包。其他适用于 Ubuntu 的版本还包括 Edgy 和 Feisty。我们这里以下载适用于 Ubuntu Feisty 的 VirtualBox 1.3.8 版来介绍。你可以从这里找到对应的版本。
2. 准备依赖。VirtualBox 的正常使用需要 libxalan110 和 libxerces27 这两个包。所以,你要先行安装它们,可以使用下面的指令:
sudo apt-get install libxalan110 libxerces27
3. 安装编译工具及相关包。在安装过程中,要编译 VirtualBox 所用的内核模块。为此,你需要准备基本的编译工具及包,你可以使用下列指令来安装它们:
sudo apt-get install build-essential linux-headers-`uname -r`
4. 现在,转到所保存 VirtualBox 安装包的目录,通过下面的指令来安装它:
sudo dpkg -i VirtualBox_1.3.8_Ubuntu_feisty_i386.deb
注意,我们这里是以 Ubuntu Feisty 为例,如果你在其他 Ubuntu 版本中安装,请使用相应的安装包代替。在安装的过程中,VirtualBox 会要求你接受许可协议。另外,安装程序也会创建 vboxusers 用户组,并编译所需的内核模块。
5. 现在,你还不能启动 VirtualBox,因为你的当前用户还不属于 vboxusers 用户组。你可以使用下面的指令来将当前的用户添加到 vboxusers 用户组中:
sudo adduser xu vboxusers
同样的,请使用你的用户名代替指令中的“xu”。

VirtualBox 默认是安装到 /opt/VirtualBox-x.x.x 目录,其中 x.x.x 代表 VirtualBox 的版本号。你可以直接在终端中敲入 VirtualBox 启动程序。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译