Permission Denied 是怎么回事?

为当前最终发行版之前的所有版本提供支持
头像
yunch
帖子: 83
注册时间: 2007-07-02 20:21
送出感谢: 0
接收感谢: 0

Permission Denied 是怎么回事?

#1

帖子 yunch » 2007-09-18 17:52

请问这个问题怎样解决?
root@chy:/home/cheny/abqus/abaqus6.7-linux# /home/cheny/abqus/abaqus6.7-linux/setup
bash: /home/cheny/abqus/abaqus6.7-linux/setup: Permission denied
上次由 yunch 在 2007-09-18 18:49,总共编辑 1 次。
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 BigSnake.NET » 2007-09-18 18:02

没有执行权限
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
yunch
帖子: 83
注册时间: 2007-07-02 20:21
送出感谢: 0
接收感谢: 0

#3

帖子 yunch » 2007-09-18 18:16

BigSnake.NET 写了:没有执行权限
root 账号还需要执行权限吗?
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#4

帖子 leeaman » 2007-09-18 18:20

好像ubuntu下面要给文件加可执行才行,不关root的事
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
头像
yunch
帖子: 83
注册时间: 2007-07-02 20:21
送出感谢: 0
接收感谢: 0

#5

帖子 yunch » 2007-09-18 18:45

leeaman 写了:好像ubuntu下面要给文件加可执行才行,不关root的事
请问怎样加可执行文件?
头像
yunch
帖子: 83
注册时间: 2007-07-02 20:21
送出感谢: 0
接收感谢: 0

#6

帖子 yunch » 2007-09-18 18:48

经常出现这样的事情,从移动硬板或光盘拷贝来的文件出现权限问题,也可能是Ubuntu的缺陷
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#7

帖子 leeaman » 2007-09-18 18:48

文件浏览器,文件上右键
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
头像
yunch
帖子: 83
注册时间: 2007-07-02 20:21
送出感谢: 0
接收感谢: 0

#8

帖子 yunch » 2007-09-18 18:55

谢谢这位大侠,问题解决,呵呵
好事做到底,又出现这个这个怎么办哪?

cheny@chy:~/OPT/ABAQUS$ /home/cheny/abqus/setup -nosystemchecks
bash: /home/cheny/abqus/setup:无法执行二进制文件
头像
yunch
帖子: 83
注册时间: 2007-07-02 20:21
送出感谢: 0
接收感谢: 0

#9

帖子 yunch » 2007-09-18 18:58

运行时大概要调用这个文件
install.bin
它是含有shell command and binary data
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#10

帖子 leeaman » 2007-09-18 18:59

试试

代码: 全选

sudo bash  /home/cheny/abqus/setup -nosystemchecks 
你装的是什么东西,是不是坏了? or

代码: 全选

sudo sh install.bin
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
头像
yunch
帖子: 83
注册时间: 2007-07-02 20:21
送出感谢: 0
接收感谢: 0

#11

帖子 yunch » 2007-09-18 19:34

安装的是ABAQUS有限元软件
第一个命令出现的是同样的结果

sudo sh install.bin

安装文件中有两个install.bin

试了其中一个给出如下问题

代码: 全选

Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...
nawk: cmd. line:6: warning: escape sequence `\.' treated as plain `.'

Launching installer...

'SWING' UI not supported by VM.  Reverting to AWT.
Invocation of this Java Application has caused an InvocationTargetException. This application will now exit. (LAX)

Stack Trace:
java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit
   at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
   at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(libgcj.so.70)
   at java.awt.Window.<init>(libgcj.so.70)
   at java.awt.Frame.<init>(libgcj.so.70)
   at java.awt.Frame.<init>(libgcj.so.70)
   at com.zerog.ia.installer.LifeCycleManager.g(DashoA8113)
   at com.zerog.ia.installer.LifeCycleManager.h(DashoA8113)
   at com.zerog.ia.installer.LifeCycleManager.a(DashoA8113)
   at com.zerog.ia.installer.Main.main(DashoA8113)
   at java.lang.reflect.Method.invoke(libgcj.so.70)
   at com.zerog.lax.LAX.launch(DashoA8113)
   at com.zerog.lax.LAX.main(DashoA8113)
Caused by: java.lang.NoClassDefFoundError: gnu.java.awt.peer.gtk.GtkToolkit
   at java.lang.Class.initializeClass(libgcj.so.70)
   at java.lang.Class.forName(libgcj.so.70)
   at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
   ...11 more
This Application has Unexpectedly Quit: Invocation of this Java Application has caused an InvocationTargetException. This application will now exit. (LAX)
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#12

帖子 BigSnake.NET » 2007-09-18 19:43

yunch 写了:
BigSnake.NET 写了:没有执行权限
root 账号还需要执行权限吗?
是的

不就是个 chmod +x 么..
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
yunch
帖子: 83
注册时间: 2007-07-02 20:21
送出感谢: 0
接收感谢: 0

#13

帖子 yunch » 2007-09-18 19:57

这样呀!
头像
woodlinux
帖子: 158
注册时间: 2006-07-15 7:29
来自: 宁波北仑
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 woodlinux » 2007-09-18 22:21

是“没有执行权限”
可以用chown和chmod两个命令设置哟
头像
yunch
帖子: 83
注册时间: 2007-07-02 20:21
送出感谢: 0
接收感谢: 0

#15

帖子 yunch » 2007-09-18 22:53

woodlinux 写了:是“没有执行权限”
可以用chown和chmod两个命令设置哟
这个设置没用,已经是那个用户的了,还要再设置吗?不需要了吧!
回复

回到 “老旧版本支持”