新手诚恳求助

为当前最终发行版之前的所有版本提供支持
回复
头像
wangwentao24
帖子: 340
注册时间: 2007-09-07 9:02
来自: 中国辽宁抚顺
送出感谢: 0
接收感谢: 0
联系:

新手诚恳求助

#1

帖子 wangwentao24 » 2007-09-22 19:31

我原先安装的是三系统XP UBUNTU 红帽子 现在想卸载 XP 和红帽子 请问怎么办阿
请问用源码怎么安装软件 和红帽子一样么
。/CONFIGURE
MAKE
MAKE INSTALL
是这样么
但是总说我 有错误阿 是不是应该安装什么编译器阿
清说的详细一些好么
谢谢了 各位高手阿/////////////
头像
86Ubuntu
帖子: 369
注册时间: 2006-12-21 17:54
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 86Ubuntu » 2007-09-22 19:38

By default, Ubuntu does not come with the tools required. You need to install the package build-essential to work with most of these packages. And since you may want to get code some projects with no released version, you should install the packages cvs and subversion as well if you think you'll need them. You should then build a common directory for yourself where you'll be building these packages. I recommend creating /usr/local/src, but really you can put it anywhere you want. Make sure this directory is writable by your primary user account, by running sudo chown username /usr/local/src and just to be safe sudo chmod u+rwx /usr/local/src. After you've done this, you're set up to start getting the programs you need.

默认情况下,Ubuntu并不预装需要的工具。你需要安装build-essential包,以便处理大部分的软件包。既然你可能想要得到一些不提 供发行版的项目的代码,你应该同时安装cvs和subversion包————如果你觉得你需要它们。接着你应该为你自己建立一个普通的目录,你将在这个目录下制作软件包。我建议创建/usr/local/src,并运行sudo chown username /usr/local/src,以及 sudo chmod u+rwx /usr/local/src(後者只是出于安全考虑)。做完这个,你可以开始安装了,先设法获得你需要的程序(源码)

代码: 全选

 
传说中,他有着绝对精彩和浪漫的身手
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

#3

帖子 Element » 2007-09-22 19:47

Synaptic 不能满足你的要求吗?
从源码安装要解决依赖问题
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
头像
wangwentao24
帖子: 340
注册时间: 2007-09-07 9:02
来自: 中国辽宁抚顺
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 wangwentao24 » 2008-02-20 0:00

谢谢 才有空处理这些贴子呵呵
回复

回到 “老旧版本支持”