当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]大虾们帮忙看看!!xorg.conf (问题已自行解决,并留参考)
帖子发表于 : 2007-09-23 4:48 

注册: 2006-04-10 11:55
帖子: 37
地址: 上海市
送出感谢: 0 次
接收感谢: 0 次
新安装的7.04
安装了NVIDIA-Linux-x86-100.14.19-pkg1.run
然后生成的xorg.conf 就是不能启动
后来也试了旧的驱动,也是不行,试了源里的驱动,还是不行。
帮忙看看这个文件有啥问题!!


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Wed Sep 12 14:29:35 PDT 2007

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "SyncMaster931BW"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "nVidia Corporation NV34 [GeForce FX 5500]"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV34 [GeForce FX 5500]"
Monitor "SyncMaster931BW"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1440x900"
EndSubSection
SubSection "Display"
Depth 4
Modes "1440x900"
EndSubSection
SubSection "Display"
Depth 8
Modes "1440x900"
EndSubSection
SubSection "Display"
Depth 15
Modes "1440x900"
EndSubSection
SubSection "Display"
Depth 16
Modes "1440x900"
EndSubSection
SubSection "Display"
Depth 24
Modes "1440x900_60"
EndSubSection
EndSection


最后由 yjxlove 编辑于 2007-09-23 6:52,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-09-23 6:51 

注册: 2006-04-10 11:55
帖子: 37
地址: 上海市
送出感谢: 0 次
接收感谢: 0 次
重装 并按以下步骤操作 问题得到解决
代码:
7.安装显卡驱动程序(我的显卡是nv7050 默认没有驱动需要安装)

(1)去www.nvidia.com下载最新的驱动:NVIDIA-Linux-x86-100.14.11-pkg1.run

(2)终端运行:sudo apt-get install build-essential pkg-config xserver-xorg-dev linux-headers-`uname -r`

(3)删除两个已有文件:

终端运行:sudo rm -f /etc/init.d/nvidia-glx

sudo rm -f /etc/init.d/nvidia-kernel

(4)修改linux-restricted-modules-common

终端运行:sudo gedit /etc/default/linux-restricted-modules-common

修改其中的 DISABLED_MODULES="",改为:DISABLED_MODULES="nv nvidia_new"

(5)终端运行:rm -f /lib/linux-restricted-modules/.nvidia_new_installed

(6)xWindows桌面按alt+ctrl+f2,并登陆

(7)$sudo /etc/init.d/gdm stop

(Cool安装驱动: $sudo sh xxxx.run (如果提示缺少某某模块(modules,kernel),询问是否上网下载,选no;其它选yes或ok)

(9)装好后 $sudo /etc/init.d/gdm start 重启xWindows


为后来的同志留点参考:

7.04 并升级完所有补丁(2007-9-22)

本人电脑配置:
AMD 2500+
FX 5500
升技 KV7
DDR 1G
三星 SyncMaster 931BW
西部数据 SATA 320G(企业版)

安装完驱动后 用 Nvidia X Server Settings 生成了xorg.conf放在桌面上

备份原有xorg.conf后
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak1

将新的配置文件覆盖进去
sudo cp /home/xxx/Desktop/xorg.conf /etc/X11/xorg.conf.bak[/code]


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-11-28 10:06 
头像

注册: 2007-05-06 2:01
帖子: 889
地址: 特麓村->浦北->五山->罗湖
送出感谢: 2
接收感谢: 0 次
我昨晚试图安装NVIDIA-Linux-x86-169.04-pkg1.run 提示错误说不能在启动Xserver的模式下安装~~~

引用:
将新的配置文件覆盖进去
sudo cp /home/xxx/Desktop/xorg.conf /etc/X11/xorg.conf.bak

ps.:上面这句是不是写错了~?不是覆盖xorg.conf的咩?


_________________
Ubuntu 9.04 & Win Xp
------------------------------------------------------
Company: http://www.mazingtech.com
HomePage: http://www.arsui.com


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译