[问题]显卡安装的问题

为当前最终发行版之前的所有版本提供支持
回复
fucj
帖子: 78
注册时间: 2006-05-04 12:02
送出感谢: 0
接收感谢: 0

[问题]显卡安装的问题

#1

帖子 fucj » 2007-09-23 10:22

我的显卡是ati9600,通过论坛上的步骤,下载比较新的ati-driver-installer-8.40.4-x86.x86_64.run驱动安装,安装到sudo module-assistant install fglrx 的 时候出现报错:
#
dh_testroot
#
rm -f configure-stamp
#
rm -f fglrx.ko fglrx.mod.c *.o libfglrx_ip.a
#
rm -f .version .*.o.flags .*.o.d .*.o.cmd .*.ko.cmd
#
rm -rf .tmp_versions
#
rm -rf patch
#
dh_clean
#
rm /usr/src/modules/fglrx/debian/control
#
rm /usr/src/modules/fglrx/debian/dirs
#
if [ -f /usr/src/modules/fglrx/debian/control.template ]; then \
#
cat /usr/src/modules/fglrx/debian/control.template > /usr/src/modules/fglrx/debian/control; \
#
fi
#
if [ -f /usr/src/modules/fglrx/debian/postinst ]; then \
#
mv /usr/src/modules/fglrx/debian/postinst /usr/src/modules/fglrx/debian/fglrx-kernel-2.6.22-2-686.postinst; \
#
fi
#
dh_testdir
#
touch configure-stamp
#
dh_testdir
#
/usr/bin/make -C /lib/modules/2.6.22-2-686/build SUBDIRS=/usr/src/modules/fglrx modules
#
make[1]: Entering directory `/usr/src/linux-headers-2.6.22-2-686'
#
CC [M] /usr/src/modules/fglrx/firegl_public.o
#
/usr/src/modules/fglrx/firegl_public.c: In function ‘__ke_pci_find_device’:
#
/usr/src/modules/fglrx/firegl_public.c:1886: warning: ‘pci_find_device’ is deprecated (declared at include/linux/pci.h:477)
#
/usr/src/modules/fglrx/firegl_public.c: In function ‘__ke_request_irq’:
#
/usr/src/modules/fglrx/firegl_public.c:2829: warning: ‘deprecated_irq_flag’ is deprecated (declared at include/linux/interrupt.h:66)
#
/usr/src/modules/fglrx/firegl_public.c:2829: warning: passing argument 2 of ‘request_irq’ from incompatible pointer type
#
/usr/src/modules/fglrx/firegl_public.c: At top level:
#
/usr/src/modules/fglrx/firegl_public.c:5306: warning: ‘kmem_cache_t’ is deprecated
#
LD [M] /usr/src/modules/fglrx/fglrx.o
#
Building modules, stage 2.
#
MODPOST 1 modules
#
CC /usr/src/modules/fglrx/fglrx.mod.o
#
LD [M] /usr/src/modules/fglrx/fglrx.ko
#
make[1]: Leaving directory `/usr/src/linux-headers-2.6.22-2-686'
#
dh_testdir
#
dh_testroot
#
dh_clean -k
#
rm -f /usr/src/modules/fglrx/debian/control /usr/src/modules/fglrx/debian/dirs
#
sed -e 's/#KVERS#/2.6.22-2-686/g' \
#
-e 's/#VERSION#/8.40.4-1/g' debian/control.template > /usr/src/modules/fglrx/debian/control
#
sed -e 's/#KVERS#/2.6.22-2-686/g' debian/dirs.template > /usr/src/modules/fglrx/debian/dirs
#
dh_installdirs
#
dh_install fglrx.ko lib/modules/2.6.22-2-686/misc
#
dh_testdir
#
dh_testroot
#
dh_installdocs
#
dh_installmodules
#
dh_link
#
dh_strip
#
dh_compress
#
dh_fixperms
#
dh_installdeb
#
dh_gencontrol -- -v8.40.4-1+2.6.22-4
#
dh_md5sums
#
dh_builddeb --destdir=/usr/src
#
dpkg-deb:正在新建软件包“fglrx-kernel-2.6.22-2-686”,包文件为“/usr/src/fglrx-kernel-2.6.22-2-686_8.40.4-1+2.6.22-4_i386.deb”。
#
dh_testroot
#
rm -f configure-stamp
#
rm -f fglrx.ko fglrx.mod.c *.o libfglrx_ip.a
#
rm -f .version .*.o.flags .*.o.d .*.o.cmd .*.ko.cmd
#
rm -rf .tmp_versions
#
rm -rf patch
#
dh_clean
#
rm /usr/src/modules/fglrx/debian/control
#
rm /usr/src/modules/fglrx/debian/dirs
#
Build time: 5 seconds
#
computer:~$
我看到这里似乎没有致命的错误,不过又些 warning,但是就是通不过,有谁知道问题出在哪里了吗?
回复

回到 “老旧版本支持”