[问题] 不知道intel 芯片的MACBOOKPOR能不能安装Ubuntu

为当前最终发行版之前的所有版本提供支持
selenefox
帖子: 15
注册时间: 2007-10-05 8:00
送出感谢: 0
接收感谢: 0

[问题] 不知道intel 芯片的MACBOOKPOR能不能安装Ubuntu

#1

帖子 selenefox » 2007-10-05 8:13

RT ,不知道有没人作过这样的实验,在Intel芯片的MAC里安装,因为Intel不属于PPC的GX芯片的,但是有和PPC一样所没有BIOS,所以安装过程因该比较麻烦的说,望高人指点一二
头像
millenniumdark
论坛版主
帖子: 4159
注册时间: 2005-07-02 14:41
系统: Ubuntu 14.04 (Kylin)
送出感谢: 42 次
接收感谢: 9 次
联系:

#2

帖子 millenniumdark » 2007-10-05 14:11

linux kernel早就支持那个intel的新"bios"了。不过我的是旧mac,所以没有这方面的经验。

但事实上是可以的,你可以看官方的wiki和论坛。

https://help.ubuntu.com/community/MacBook

http://ubuntuforums.org/showthread.php?t=198453

另,转到安装配制。
selenefox
帖子: 15
注册时间: 2007-10-05 8:00
送出感谢: 0
接收感谢: 0

#3

帖子 selenefox » 2007-10-06 14:25

3Q 我已经在大胆的测试了 ,看看mac的笔记本能不能比较好的支持ubuntu
头像
walkerinrain314
帖子: 60
注册时间: 2007-09-28 9:33
来自: 广东深圳
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 walkerinrain314 » 2007-10-06 15:46

理论上来说应该可以!强烈建议楼主去试试。!并预祝您成功!
男人无所谓正派,
正派是因为受到的引诱不够;
女人无所谓忠诚,
忠诚是因为背叛的筹码太低!
头像
freedom8971
帖子: 182
注册时间: 2007-08-05 2:50
送出感谢: 0
接收感谢: 0

#5

帖子 freedom8971 » 2007-10-06 17:42

:D 同意4Floor......理论上可以......具体结果楼主替人民群众试验一下吧.....人民会记住你的伟大的..... :cry:
图片
selenefox
帖子: 15
注册时间: 2007-10-05 8:00
送出感谢: 0
接收感谢: 0

#6

帖子 selenefox » 2007-10-07 17:16

Live CD 启动不起来,还在研究中,不知道有没人成功安装过,我在网上看到的是MACBOOK是成功安装的,没有看到过MACBOOKPRO成功安装的任何资料,太尴尬了
mmhssxa
帖子: 2
注册时间: 2007-10-25 0:33
送出感谢: 0
接收感谢: 0

#7

帖子 mmhssxa » 2007-11-03 3:32

安装是没有问题的
但是就是如果你的MBP用得是AR5008X的无线网卡的话,这个就是一个很大的问题!
最少说我这几天一直在查找解决办法,但还是没有结果!但愿新的MADWIFI0.94能解决这个问题咯!
其他的基本是没有问题的,具体会有一些小的问题需要修改一下的,网上搜一下就有很多教程的!基本都是英文的!
mmhssxa
帖子: 2
注册时间: 2007-10-25 0:33
送出感谢: 0
接收感谢: 0

#8

帖子 mmhssxa » 2007-11-03 3:34

selenefox 写了:Live CD 启动不起来,还在研究中,不知道有没人成功安装过,我在网上看到的是MACBOOK是成功安装的,没有看到过MACBOOKPRO成功安装的任何资料,太尴尬了
先用BOOTCAMP分区,然后直接从新启动就可以找到了阿!
实在不行开机按着C键就是光盘启动阿!
头像
evilaqua
帖子: 170
注册时间: 2007-09-13 14:06
送出感谢: 0
接收感谢: 0

#9

帖子 evilaqua » 2007-11-03 10:18

Ubuntu不是有FOR MAC版的吗?以前我申请6.06版的时候就要了一个PC32位,一个PC64位,还有一个MAC版的。
《十月坊》耳机专卖店
淘宝网店址:http://shop33926725.taobao.com
拍拍网店址:http://shop.paipai.com/33265685
头像
i138
帖子: 46
注册时间: 2007-01-25 12:13
送出感谢: 0
接收感谢: 0

#10

帖子 i138 » 2007-11-03 12:39

mmhssxa 写了:安装是没有问题的
但是就是如果你的MBP用得是AR5008X的无线网卡的话,这个就是一个很大的问题!
最少说我这几天一直在查找解决办法,但还是没有结果!但愿新的MADWIFI0.94能解决这个问题咯!
其他的基本是没有问题的,具体会有一些小的问题需要修改一下的,网上搜一下就有很多教程的!基本都是英文的!
看我的帖子:
viewtopic.php?t=85819

ubuntu7.10自带的madwifi是无法支持AR5006以后的无线网卡的.
ar5007,ar5008都可以在ubuntu里面用...前提条件,删掉默认安装的madwifi.
然后使用ndiswrapper+windowsXP驱动.
品品工夫茶,玩玩北京浮生记www.sun0768.com.cn
selenefox
帖子: 15
注册时间: 2007-10-05 8:00
送出感谢: 0
接收感谢: 0

#11

帖子 selenefox » 2007-11-03 20:09

小弟不才,已经弄了差不多了,前段时间公司的事情多,没有及时在这里向大家汇报进度,现在和大家说下进度。我上面说的光盘启动的错误并不是光盘没办法引导,是引导后键盘无法使用,很不可思议的错误,我后来的解决办法是在接个USB键盘,进去后把键盘再去掉,可能是MAC笔记本的工业设计的特殊造成的。
我现在已经把UBUNTU已经完整的装好了,就差一个无线网卡没有搞定,还在研究中~~~ 显卡部分最麻烦,不过ATI的最新的8.42.3出了太及时了,至少3D桌面运行是没有问题的,现在还在解决Compiz Fusion的支持,因为不知道是ATI 驱动不支持还是我安装的方式不对,Compiz Fusion无法启动。谢谢个位的关注~~~
ubuntu下装了个jdk 1.4.2 和jdk1.6 因为Eclipse5.5.1需要用到1.6,公司服务器却是用1.4.2没办法只好装两个jdk了,呵呵呵呵,装好了才想起来可以直接装jre1.6的 >_< ,感觉运行效率还行,和我MAC下的Eclipse不相上下,呵呵呵呵~~~ 顺便说下,ubuntu下的jre运行环境不好,用java的同志门最好装个jdk,这样运行效率比ubuntu的那个高多了~~~~
selenefox
帖子: 15
注册时间: 2007-10-05 8:00
送出感谢: 0
接收感谢: 0

#12

帖子 selenefox » 2007-11-03 20:12

在补充下,ubuntu下的无线网卡并没有出现在受限驱动里面,这样我都不知道如何去装他了,比较郁闷的
头像
Nile
帖子: 990
注册时间: 2006-07-15 11:20
来自: 枫叶刀市
送出感谢: 2 次
接收感谢: 0

#13

帖子 Nile » 2007-11-03 20:23

evilaqua 写了:Ubuntu不是有FOR MAC版的吗?以前我申请6.06版的时候就要了一个PC32位,一个PC64位,还有一个MAC版的。
FOR MAC应该指的是Power架构的老MAC了吧,apple换芯后自然要换成x86架构的i386或AMD64了
Thinkpad T400
selenefox
帖子: 15
注册时间: 2007-10-05 8:00
送出感谢: 0
接收感谢: 0

#14

帖子 selenefox » 2007-11-03 20:40

是的,那个For Mac 的版本是要G4 G5的那种芯片的,现在的就可以直接装普通的PC版本的
vincentzhu
帖子: 24
注册时间: 2007-03-18 23:44
送出感谢: 0
接收感谢: 0

#15

帖子 vincentzhu » 2007-11-06 23:23

半个月前在我的macbook第二代(T7200的CPU)上面装了ubuntu7.10. 可以说什么都支持,无线网卡,trackpad的右击,scrolling都支持的很好,休眠也支持的挺好的,不过感觉休眠的启动速度没有mac os x 下面来得快。

详细情况可以参考官方的wiki,不过是英文的。

https://help.ubuntu.com/community/MacBook
selenefox 写了:Live CD 启动不起来,还在研究中,不知道有没人成功安装过,我在网上看到的是MACBOOK是成功安装的,没有看到过MACBOOKPRO成功安装的任何资料,太尴尬了
回复

回到 “老旧版本支持”