[问题]PDF中文支持的问题

为当前最终发行版之前的所有版本提供支持
回复
sinomen
帖子: 11
注册时间: 2007-08-31 16:17
送出感谢: 0
接收感谢: 0

[问题]PDF中文支持的问题

#1

帖子 sinomen » 2007-10-05 14:06

我从网上下了一套精装的二十五史的精装版pdf文件,在win下显示一切正常,但是在ubuntu里显示就是有问题,我的pdf文件里别的大部分文件中文字都正常,但是这个不行,我把《陈书》放上,大家看看有没有好办法解决问题。
附件
Screenshot.png
截屏图像
S40.PDF.tar.gz
陈书文本
(958.18 KiB) 下载 81 次
头像
aca
帖子: 129
注册时间: 2007-04-22 13:23
送出感谢: 0
接收感谢: 0

#2

帖子 aca » 2007-10-05 14:13

下一个中文pdf 软件就好了
想象你在身边
wkt
帖子: 849
注册时间: 2006-09-07 22:51
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 wkt » 2007-10-05 14:22

安装xpdf-chinese-simplified试试
反正我这样就ok了!
我用的是 evince
sinomen
帖子: 11
注册时间: 2007-08-31 16:17
送出感谢: 0
接收感谢: 0

#4

帖子 sinomen » 2007-10-05 17:39

我用的就是evince,包括kpdf和xpdf都试了,我的中文插件xpdf-chinese-simplified和繁体插件斗已经安装了,没用,因为其他的大部分文档中文显示都没有问题,只是这批文件有这样的问题,包括论坛上的一些比较难显示的在我这儿也没有问题,你们可以把我传上的这个文档下载打开试试就知道了,希望能有人知道解决方法。
据了解这批文档是方正做得,会不会和它的apabi格式有关?
另:版主可否把我的帖子移到中文支持栏目里,我发完了,才发现应该放在那儿更合适,但是我没法移帖子。谢谢
robert870119
帖子: 768
注册时间: 2007-03-05 20:45
送出感谢: 0
接收感谢: 0

#5

帖子 robert870119 » 2007-10-05 17:42

安装adobe reader 8.11 试试吧
sinomen
帖子: 11
注册时间: 2007-08-31 16:17
送出感谢: 0
接收感谢: 0

#6

帖子 sinomen » 2007-10-05 18:08

正在论坛提供的链接下8.1.1,但是那个中文语言包下载的链接好像有点问题,下载的字节数为0,
我刚才用wine打开了FOXIT2.1,发现文字显示没有问题,但是极其不稳定,非常容易自动关闭,
也许是我的WINE有些问题吧,因为我的wine是直接通过源进行安装的,可能不太适用。
头像
juanzhewudi
帖子: 1114
注册时间: 2006-01-19 11:55
来自: HUST
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 juanzhewudi » 2007-10-05 18:15

这个文档确实怪异。。
不过adobe有linux版本的adobe reader,何不试试。。。虽然哪个破玩意的中文包很难下到。。
buhuan
帖子: 183
注册时间: 2007-09-27 15:37
送出感谢: 0
接收感谢: 0

#8

帖子 buhuan » 2007-10-05 18:16

我用了xpdf和evince,加了中文包也不行
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#9

帖子 eexpress » 2007-10-05 18:42

看属性,如果是gb2312的过时编码,就别想了。
● 鸣学
gtr999
帖子: 107
注册时间: 2007-01-19 4:09
送出感谢: 0
接收感谢: 0

#10

帖子 gtr999 » 2007-10-05 18:52

的确是gb2312的编码
sinomen
帖子: 11
注册时间: 2007-08-31 16:17
送出感谢: 0
接收感谢: 0

#11

帖子 sinomen » 2007-10-05 18:58

abode reader 8.1.1我已经安装了,中文包也安装了,但是仍然不行,提示什么GB2312找不到,不知道谁有招可以解决
sinomen
帖子: 11
注册时间: 2007-08-31 16:17
送出感谢: 0
接收感谢: 0

#12

帖子 sinomen » 2007-10-05 19:08

看来是没希望了,只能在win下看了。不过在win下,能不能通过什么软件把它的编码从2312转成18030呢
coolskyboy
帖子: 28
注册时间: 2007-09-23 9:35
送出感谢: 0
接收感谢: 0

#13

帖子 coolskyboy » 2007-10-05 20:52

我最后还是下了ADOBE的了..
头像
qianwx
帖子: 730
注册时间: 2006-07-08 14:41
送出感谢: 0
接收感谢: 0

#14

帖子 qianwx » 2007-10-05 21:59

呵呵,本来嘛 ,既然有大公司官方版本,为什么不用呢???虽然容量大了些,但胜在东西好阿。总比那些开源的要强一些吧???并不是看不起开源的,只是无论如何,开源的一般情况下是无法和专业大公司的产品比的。我想多数linux用户如果不是磁盘空间紧张的话,一般是能用官方版本都会尽量使用官方的吧?除非官方版本有什么缺陷。。
回复

回到 “老旧版本支持”