当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [求助]还是关于SATA硬盘,无法识别
帖子发表于 : 2007-10-05 15:46 

注册: 2007-10-05 15:13
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
Greeting, 我前两天弄了台二手机,自己配了个LG 19''宽频显示器,目前在OS安装方面遇到严重问题,我已经在GOOGLE和wiki上看了不少文章了,问题还是无法解决,所以来求助:

我的机器配置是这样的:Compaq Presario SR1850NX

CPU: AMD 64bits 3700+
RAM: OCZ DDR SDRAM 2*1G.
HDD: 250 7200RPM SATA (牌子查不到,还没有拆机看)
硬盘是主要问题
M.B.: ATI SouthBridge Xpress200
显卡集成,声卡创新X-FI AUDIO(目前先不关心驱动的问题)

我之前在我室友的电脑上弄过,用的是AMD 64 7.04的碟,工作相当正常
而现在我遇到的问题比较显然是SATA硬盘驱动由截图可知:
图片
图片
图片

根据读的文章大致应该是SATA缺乏驱动(虽然的确很多人说他们的SATA硬盘安装成功了)
而在LIVECD 的TERMINAL里面无法运行listpci,所以求助有没有什么别的方法让UBUNTU识别SATA的。

7.10BETA我也试过了,直接连显示器都调整有误(宽屏强行变成了方屏解析度,其余部分黑屏)
另外我试装过MAC OSX 10.4.9 uphuck版,但在这部机子上也无法安装,连安装界面都进不去,只说 STILL WAITTING FOR THE ROOT DEVICE,然后不动了...莫非也和SATA有关系?

多谢大家的回复,中文有点退化了,不好意思。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-05 15:56 

注册: 2007-10-05 15:13
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
顺便加一句:在DOS下使用个别硬盘修复软件也无法识别硬盘,只有PQ可以...不知道是不是因为用那个分区导致的问题,如果是的话,如何可以彻底把硬盘恢复出场设定呢?谢谢。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-10-05 16:08 
头像

注册: 2005-12-28 1:16
帖子: 3916
地址: 火星
系统: Ubuntu 12.10 X64
送出感谢: 1
接收感谢: 0 次
pq也能引起同样的问题


_________________
目前负债150多万


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-10-05 16:10 
头像

注册: 2006-07-08 14:41
帖子: 730
送出感谢: 0 次
接收感谢: 0 次
理论上,硬盘无论是否能识别,都能正常驱动,前提是你的IDE控制器能正确驱动起来。建议你看看你的主板是否正确安装了所有驱动


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-10-05 16:48 

注册: 2007-10-05 15:13
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
驱动应该是都装了,本来是品牌机,所以什么驱动碟好像也没有。我打开BIOS看了一下,硬盘ID是ST3250823AS,也就是希捷barracuda SATA I 硬盘。另外BIOS里面SATA ADAPTER已经enable了,有个Local Bus IDE Adapter, 里面的选项有Disabled, Primary, Secondary, Both(默认),我试了一下Primary,结果2个光驱都找不到了。

xhy的意见是问题可能在PQ上?如果是有没有办法让硬盘回复出场设置?(就是变成一块raw disk)

另外还有就是既然是品牌机,会不会有什么隐藏分区储存了东西导致问题出现呢?因为现在可以装xp,所以感觉问题还是出在OS对DISK的识别上。

谢谢回复。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-10-05 22:47 
头像

注册: 2006-07-08 14:41
帖子: 730
送出感谢: 0 次
接收感谢: 0 次
你可能搞错我的意思了,我是指你的ide控制器驱动在linux系统中是否正确安装了。。。。windows当然不会有问题,系统认不出还有生产商提供windows下的主板驱动(其中就包括了ide控制器驱动),而这些生产商不见得都能提供linux版本的主板驱动。。因此,很多过于新的主板(例如具备ich8的主板)在绝大多数linux系统中都无法正确驱动ich8控制器(该控制器就是ide控制器,也就是使得硬盘能正确使用的设备),你可以试试看在bios中关闭sata驱动,打开模拟IDE驱动。。这样一般都能获得更好的兼容性。

注:XP的某些版本在DOS下安装就需要在主板BIOS中关闭sata,打开模拟的IDE来实现安装。。原因就是这些版本的XP(比如SP1以前的版本)无法识别SATA设备。而打开模拟IDE驱动之后,就能让操作系统把这个SATA设备认作是普通IDE设备!

另:你也可以看看你的硬盘跳线,我记得某些SATA硬盘有个跳线也可以让系统识别为IDE设备而不是SATA设备,当然,如此跳的话,性能将会下降。

我个人认为并不是软件问题,也不是系统认不出SATA硬盘,而是系统缺乏ICH控制器驱动!没有正确的ICH驱动,也就无法识别特殊硬盘。但如果硬盘是IDE的,我估计即便没有正确安装ICH驱动,也应该能识别的。所以我才建议你试试看在BIOS或硬盘上设置关闭SATA界面打开IDE模拟。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-10-05 22:58 
头像

注册: 2006-07-08 14:41
帖子: 730
送出感谢: 0 次
接收感谢: 0 次
我说说我的配置吧,从这些你应该能看出一些问题的。。。
显卡:和主题无关,不说了。
硬盘:希捷SATA 320G最新的版本。
主版:intel865PE(很经典的芯片组吧?ICH5的控制器)
其他:和问题无关不说了。

我的操作系统: XP SP2 + Ubuntu7.04。
安装一次成功,XP是dos环境光盘安装,ubuntu是LiveCD光盘安装。都能直接识别出硬盘。。

从这些你可看出,同样是SATA硬盘,我的电脑为什么就能直接识别而不存在任何问题呢?就是那个ICH5的控制器了。。。这个版本的控制器在所有目前发行版本的linux系统里都是能被直接识别并使用驱动的。因此也就能直接使用SATA硬盘!

再给你说一个例子,我朋友前几天刚买的笔记本,主版是965的,ICH8的控制器,在他的硬件系统上如果不打开IDE模拟,那么他就无法通过类似LiveCD这样的方式安装linux。。。原因是安装过程无法使用硬盘!目前的他只能通过vmware虚拟机来使用linux。。。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-10-06 14:13 

注册: 2007-10-05 15:13
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
很不幸我似乎是最后一种情况的另一个样本....

BIOS里找了半天没有SIMULATOR, 网上关于主板的信息提到这个的也很少...最后没办法...跑去买了个IDE硬盘来装Ubuntu,原来的SATA用来装VISTA。现在除创新x-fi audio声卡外硬件工作都已正常,感谢各位的指点,一定更加努力研习linux.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译