各位帮忙看看,我没法安装软件包

为当前最终发行版之前的所有版本提供支持
回复
cuculu
帖子: 3
注册时间: 2005-12-27 18:56
送出感谢: 0
接收感谢: 0

各位帮忙看看,我没法安装软件包

#1

帖子 cuculu » 2005-12-28 9:18

我是新手,刚装上ubuntu,工作需要,想装2个软件:EMBOSS;

我只能找到EMBOSS的tar.gz包,只能按照它的安装方式来了。可是怎么都装不上,后来看了看./configure以及后来输入make 、make install后的提示,发现一句相同的提示:can not find lx11

难道就是它的问题。这个lx11是什么?我需要怎么做?
苍紫云龙
帖子: 117
注册时间: 2005-07-27 18:39
送出感谢: 0
接收感谢: 0

#2

帖子 苍紫云龙 » 2005-12-28 9:35

安装libx11以及libx11-dev
源中就有
cuculu
帖子: 3
注册时间: 2005-12-27 18:56
送出感谢: 0
接收感谢: 0

#3

帖子 cuculu » 2005-12-28 10:02

谢谢楼上的。
我查看了新得立软件包管理器,发现我安装了libx11-6,这应该就是libx11了吧。不过我没发现libx11-dev,怎么看安装源里没安装的软件包?如果安装源没有,我去哪找这个libx11-dev?

我又看了一下安装失败后的提示,具体是这样描述的:
/usr/bin/ld : cannot find -lx11
colltct2: ld return 1 exit status

请看看我该怎么办?
苍紫云龙
帖子: 117
注册时间: 2005-07-27 18:39
送出感谢: 0
接收感谢: 0

#4

帖子 苍紫云龙 » 2005-12-28 11:50

cuculu 写了:谢谢楼上的。
我查看了新得立软件包管理器,发现我安装了libx11-6,这应该就是libx11了吧。不过我没发现libx11-dev,怎么看安装源里没安装的软件包?如果安装源没有,我去哪找这个libx11-dev?

我又看了一下安装失败后的提示,具体是这样描述的:
/usr/bin/ld : cannot find -lx11
colltct2: ld return 1 exit status

请看看我该怎么办?
在新立得中点搜索,输入libx11就可以找到了,安装源中应该是有的
也可以
sudo apt-get install libx11-dev
回复

回到 “老旧版本支持”