请教ubuntu下装网卡驱动安装

为当前最终发行版之前的所有版本提供支持
回复
haha_ha
帖子: 3
注册时间: 2007-10-08 20:35
送出感谢: 0
接收感谢: 0

请教ubuntu下装网卡驱动安装

#1

帖子 haha_ha » 2007-10-08 21:01

装了ubuntu7.04,网卡是3Com Gigabit NIC 3C2000
按照安装说明一步步装的,但是出现了以下的问题
如果是
#make load就会出现类似以下的错误报告

skge.c:4580: warning: passing argument 3 of ‘XmitFrame’ from incompatible p
ointer type
skge.c: In function ‘SkErrorLog’:
skge.c:4616: warning: implicit declaration of function ‘strcpy’
skge.c:4616: warning: incompatible implicit declaration of built-in function
‘strcpy’
skge.c:4637: error: ‘KERN_INFO’ undeclared (first use in this function)
skge.c:4637: error: expected ‘)’ before string constant
make: *** [skge.o] Error 1

安装说明里面指出可以"insmod 3c2000.o" ,但是为什么安装包里有没有这个“3c2000.o
”文件呢?

谢谢各位啦~~~[/code]
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 BigSnake.NET » 2007-10-08 21:08

代码: 全选

aptitude show build-essential linux-headers-2.6
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
haha_ha
帖子: 3
注册时间: 2007-10-08 20:35
送出感谢: 0
接收感谢: 0

#3

帖子 haha_ha » 2007-10-08 21:27

???为什么输入aptitude show build-essential linux-headers-2.6后

是 E: Unable to locate package build-essential
回复

回到 “老旧版本支持”