[分享]让COMPIZ 带着ATI Mobility Radeon在7.10 下玩3D 特效

为当前最终发行版之前的所有版本提供支持
回复
huangweiqiu
帖子: 68
注册时间: 2007-02-02 11:40
送出感谢: 0
接收感谢: 0

[分享]让COMPIZ 带着ATI Mobility Radeon在7.10 下玩3D 特效

#1

帖子 huangweiqiu » 2007-10-08 22:31

很多朋友的ATI 卡玩不了3D 装面,特别是升级到7.10 后。我找到了一个方法:


With a couple edits to xorg.conf you can get Compiz working pretty much out of the box without XGL enabled! SWEET and a first - the Gutsy Gibbon is looking good.

Make sure you are using the fglrx driver (See System > Administration > Screen and Graphics). Open /etc/X11/xorg.conf in your favourite editor and add the following to Section “Device” Under the Busid Option:

Option "backingstore" "true"
Option “EnablePageFlip” “true”
Option “SubPixelOrder” “none”
Option “AccelMethod” “XAA”
Option “RenderAccel” “true”
Option “AGPMode” “4″
Option “ColorTiling” “on”
Option “DynamicClocks” “on”
Option “mtrr” “on”
Option “VideoOverlay” “on”
Option “OpenGLOverlay” “off”

Check that under the Section “Extensions” that the Option “Composite” is enabled, i.e.:
Section "Extensions"
Option “Composite” “Enable”
EndSection

Finally enable Desktop Effects via System > Preferences > Appearance > Desktop Effects.
翻译
首先确保你的用的是FGLRX 驱动(系统->系统管理->Screen and Graphics)。用管理员权限打开/etc/X11/xorg.conf 文件,在 “Busid Option” 下加如以下 “section" 到 ”Device“ section,在”Busid Option“下:
Option "backingstore" "true"
Option “EnablePageFlip” “true”
Option “SubPixelOrder” “none”
Option “AccelMethod” “XAA”
Option “RenderAccel” “true”
Option “AGPMode” “4″
Option “ColorTiling” “on”
Option “DynamicClocks” “on”
Option “mtrr” “on”
Option “VideoOverlay” “on”
Option “OpenGLOverlay” “off”

检查“Extensions”“ section" 下的”Composite“选项是‘enabled "的,例如:
Section "Extensions"
Option “Composite” “Enable”
EndSection

最后一步,打开你的特效:系统选项->外观->桌面特效
重要!请牢记这个命令,它能让你在做上面的配置后无法进入桌面做恢复:
sudo dpkg-reconfigure -phigh xserver-xorg
上次由 huangweiqiu 在 2011-06-15 23:22,总共编辑 1 次。
我爱linux
MEME
帖子: 6
注册时间: 2007-09-15 12:44
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 MEME » 2007-10-10 19:58

救星啊,谢谢
回复

回到 “老旧版本支持”