[问题]关于java的问题,跪求答案

为当前最终发行版之前的所有版本提供支持
回复
xcxtxcbaggio
帖子: 27
注册时间: 2006-12-07 12:32
送出感谢: 0
接收感谢: 0
联系:

[问题]关于java的问题,跪求答案

#1

帖子 xcxtxcbaggio » 2007-10-09 14:30

请问大家,为什么我在命令行下,输入java或者javac都有反应,并且对人和一个.java文件用javac都能编译出class文件,但是为什么用java命令却不行,老是提示
xcxtxcbaggio@xcxtxcbaggio:~/java/stringandchar$ ls
hhh.java ooo.class ooo.java rrr.java string stringbuffer ttt.class ttt.java uuu.class uuu.java 数组
xcxtxcbaggio@xcxtxcbaggio:~/java/stringandchar$ javac ttt.java
xcxtxcbaggio@xcxtxcbaggio:~/java/stringandchar$ java ttt
Exception in thread "main" java.lang.NoClassDefFoundError: ttt



而且我在windows下面用eclipse的时候,也是能够编译不能执行,到底是为什么阿?
头像
windwiny
帖子: 2254
注册时间: 2007-03-13 17:26
送出感谢: 0
接收感谢: 1 次

#2

帖子 windwiny » 2007-10-09 14:58

.....你的ttt 里有main函数?
xcxtxcbaggio
帖子: 27
注册时间: 2006-12-07 12:32
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 xcxtxcbaggio » 2007-10-09 15:04

public class ttt
{
public static void main(String args[])
{
String s= "0123456789";
int i=s.length();
StringBuffer ggg=new StringBuffer(i);
for(int j=i-1;j>-1;j--)
{
ggg.append(s.charAt(j));
}
System.out.println(ggg);
}}
wkt
帖子: 849
注册时间: 2006-09-07 22:51
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 wkt » 2007-10-09 15:12

那就怪了,我这里没事:
linux@debian:/tmp
-0-$ javac ttt.java ;ls ;
gconfd-linux index.html orbit-linux ttt.class
hsperfdata_linux keyring-9w8nRz ssh-njCPoB2391 ttt.java
linux@debian:/tmp
-0-$ java ttt
9876543210
linux@debian:/tmp
-0-$ cat ttt.java
public class ttt
{
public static void main(String args[])
{
String s= "0123456789";
int i=s.length();
StringBuffer ggg=new StringBuffer(i);
for(int j=i-1;j>-1;j--)
{
ggg.append(s.charAt(j));
}
System.out.println(ggg);
}}
头像
windwiny
帖子: 2254
注册时间: 2007-03-13 17:26
送出感谢: 0
接收感谢: 1 次

#5

帖子 windwiny » 2007-10-09 15:15

不知道,我这里正常
头像
core
帖子: 209
注册时间: 2007-08-17 13:00
送出感谢: 0
接收感谢: 0

#6

帖子 core » 2007-10-09 15:27

linux 下的myeclipse下运行正常
结果:
9876543210
程序没错.
头像
core
帖子: 209
注册时间: 2007-08-17 13:00
送出感谢: 0
接收感谢: 0

#7

帖子 core » 2007-10-09 15:28

linux 下的myeclipse下运行正常
结果:
9876543210
程序没错.
xcxtxcbaggio
帖子: 27
注册时间: 2006-12-07 12:32
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 xcxtxcbaggio » 2007-10-09 15:28

就是阿,我也觉得很郁闷阿,我都是照着wiki上面的设置使用的阿
我也不知道可能哪里设置错了~~~~
oustlo
帖子: 1
注册时间: 2007-10-09 23:45
送出感谢: 0
接收感谢: 0

#9

帖子 oustlo » 2007-10-09 23:49

。。。。。。。。。。
偶的问题和你一样,似乎是java版本冲突。
找寻答案中。。。
头像
redsdh
帖子: 67
注册时间: 2006-11-08 16:50
送出感谢: 0
接收感谢: 0

#10

帖子 redsdh » 2007-10-09 23:55

你有没有在CLASSPATH里设置当前目录哇!!
回复

回到 “老旧版本支持”