sudo apt-get install libopenssl-ruby 不成功

为当前最终发行版之前的所有版本提供支持
回复
liyu212
帖子: 17
注册时间: 2007-07-19 14:35
送出感谢: 0
接收感谢: 0

sudo apt-get install libopenssl-ruby 不成功

#1

帖子 liyu212 » 2007-10-10 22:07

sudo apt-get install libopenssl-ruby
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
libopenssl-ruby 已经是最新的版本了。
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
bind9-host: 依赖: libssl0.9.8 (>= 0.9.8c-1) 但是 0.9.8a-7ubuntu0.4 正要被安装
dnsutils: 依赖: libssl0.9.8 (>= 0.9.8c-1) 但是 0.9.8a-7ubuntu0.4 正要被安装
libdns22: 依赖: libssl0.9.8 (>= 0.9.8c-1) 但是 0.9.8a-7ubuntu0.4 正要被安装
libneon26: 依赖: libssl0.9.8 (>= 0.9.8c-1) 但是 0.9.8a-7ubuntu0.4 正要被安装
libopenssl-ruby1.8: 依赖: libssl0.9.8 (>= 0.9.8c-1) 但是 0.9.8a-7ubuntu0.4 正要被安装
libpq5: 依赖: libssl0.9.8 (>= 0.9.8c-1) 但是 0.9.8a-7ubuntu0.4 正要被安装
libsasl2-modules: 依赖: libssl0.9.8 (>= 0.9.8c-1) 但是 0.9.8a-7ubuntu0.4 正要被安装
nginx: 依赖: libssl0.9.8 (>= 0.9.8c-1) 但是 0.9.8a-7ubuntu0.4 正要被安装
ntpdate: 依赖: libssl0.9.8 (>= 0.9.8c-1) 但是 0.9.8a-7ubuntu0.4 正要被安装
openssh-client: 依赖: libssl0.9.8 (>= 0.9.8c-1) 但是 0.9.8a-7ubuntu0.4 正要被安装
openssh-server: 依赖: libssl0.9.8 (>= 0.9.8c-1) 但是 0.9.8a-7ubuntu0.4 正要被安装
openssl: 依赖: libssl0.9.8 (>= 0.9.8c-1) 但是 0.9.8a-7ubuntu0.4 正要被安装
php5-cgi: 依赖: libssl0.9.8 (>= 0.9.8c-1) 但是 0.9.8a-7ubuntu0.4 正要被安装
python2.5: 依赖: libssl0.9.8 (>= 0.9.8c-1) 但是 0.9.8a-7ubuntu0.4 正要被安装
quota: 依赖: libssl0.9.8 (>= 0.9.8c-1) 但是 0.9.8a-7ubuntu0.4 正要被安装
tcpdump: 依赖: libssl0.9.8 (>= 0.9.8c-1) 但是 0.9.8a-7ubuntu0.4 正要被安装
vsftpd: 依赖: libssl0.9.8 (>= 0.9.8c-1) 但是 0.9.8a-7ubuntu0.4 正要被安装
w3m: 依赖: libssl0.9.8 (>= 0.9.8c-1) 但是 0.9.8a-7ubuntu0.4 正要被安装
wget: 依赖: libssl0.9.8 (>= 0.9.8c-1) 但是 0.9.8a-7ubuntu0.4 正要被安装
wpasupplicant: 依赖: libssl0.9.8 (>= 0.9.8c-1) 但是 0.9.8a-7ubuntu0.4 正要被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
回复

回到 “老旧版本支持”