其实不是MYSQL权限问题,而是安装mysql时不支持GBK

为当前最终发行版之前的所有版本提供支持
回复
zyuz
帖子: 39
注册时间: 2007-06-11 14:11
送出感谢: 0
接收感谢: 0

其实不是MYSQL权限问题,而是安装mysql时不支持GBK

#1

帖子 zyuz » 2007-10-13 22:55

安装了mysql5,用下句:

GRANT ALL PRIVILEGES ON *.* TO 'yourusername'@'localhost' IDENTIFIED BY 'yourpassword' WITH GRANT OPTION;

对yourusername给权限,但是仍然不用安装wordpress. 因为sql语句无效,能建成数据库,但库中没有任何的表。

这是怎么回事。。
上次由 zyuz 在 2007-10-16 22:16,总共编辑 1 次。
头像
kukat
帖子: 266
注册时间: 2006-06-14 6:12
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 kukat » 2007-10-13 23:57

你确定是权限的问题?
试试phpmyadmin吧,看看你的问题到底是什么
sudo apt-get install phpmyadmin
zyuz
帖子: 39
注册时间: 2007-06-11 14:11
送出感谢: 0
接收感谢: 0

#3

帖子 zyuz » 2007-10-16 22:13

我安装了两天了,才知道,原来我安装mysq时没有支持gbk编码,而我的sql语句都强制用了gbk..


所以。。。。

谢谢大家了。
回复

回到 “老旧版本支持”