当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]升级到7.10Gutsy过程中掉线,连上后几个deb包无法下载,求方法(已解决)
帖子发表于 : 2007-10-21 12:36 
头像

注册: 2007-08-07 9:47
帖子: 30
地址: 广东茂名
送出感谢: 0 次
接收感谢: 0 次
RT

从7.04升级到7.10过程中,居然掉线了
再连上的时候
好几个包无法下载
可是复制这几个包的地址
在firefox里又可以下载
按提示用了apt-get update好几次,不行
然后加上--fix-missing,也不行
换sudo do-release-upgrade,到某一过程时停止了
Ctrl+c出现提示信息

代码:
100% [Working]Error in function stop

出现致命错误
Please report this as a bug and include the files /var/log/dist-upgrade/main.log and /var/log/dist-upgrade/apt.log in your report. The upgrade aborts now.
Your original sources.list was saved in /etc/apt/sources.list.distUpgrade.
Traceback (most recent call last):

  File "/usr/lib/python2.5/site-packages/apt/progress.py", line 117, in stop
    def stop(self):


可是我不懂这些 :cry:

那几个无法下载的包,提示是

代码:
错误 http://ubuntu.csie.ntu.edu.tw gutsy/main x11proto-randr-dev 1.2.1-2
  连接失败
错误 http://ubuntu.csie.ntu.edu.tw gutsy/main libungif4g 4.1.4-5
  连接失败
错误 http://ubuntu.csie.ntu.edu.tw gutsy/main libgnome-desktop-2 1:2.20.0-0ubuntu1
  连接失败
错误 http://ubuntu.csie.ntu.edu.tw gutsy/main viewres 1:1.0.1-0ubuntu2
  连接失败
错误 http://ubuntu.csie.ntu.edu.tw gutsy/main xlogo 1:1.0.1-0ubuntu2
  连接失败
错误 http://ubuntu.csie.ntu.edu.tw gutsy/main libopenal0a 1:0.0.8-4ubuntu2
  连接失败
错误 http://ubuntu.csie.ntu.edu.tw gutsy/main libbrlapi1 3.7.2-7.1ubuntu1
  连接失败
错误 http://ubuntu.csie.ntu.edu.tw gutsy/main xserver-xorg-video-apm 1:1.1.1-7
  连接失败
错误 http://ubuntu.csie.ntu.edu.tw gutsy/main pppconfig 2.3.17ubuntu1
  连接失败
错误 http://ubuntu.csie.ntu.edu.tw gutsy/main python-gdbm 2.5.1-1ubuntu1
  连接失败
错误 http://ubuntu.csie.ntu.edu.tw gutsy/universe gij-4.1 4.1.2-16ubuntu2
  连接失败
错误 http://ubuntu.csie.ntu.edu.tw gutsy/main libmono-cairo1.0-cil 1.2.4-6ubuntu6
  连接失败
无法下载 http://ubuntu.csie.ntu.edu.tw/ubuntu/pool/main/x/x11proto-randr/x11proto-randr-dev_1.2.1-2_all.deb  连接失败
无法下载 http://ubuntu.csie.ntu.edu.tw/ubuntu/pool/main/libu/libungif4/libungif4g_4.1.4-5_i386.deb  连接失败
无法下载 http://ubuntu.csie.ntu.edu.tw/ubuntu/pool/main/g/gnome-desktop/libgnome-desktop-2_2.20.0-0ubuntu1_i386.deb  连接失败
无法下载 http://ubuntu.csie.ntu.edu.tw/ubuntu/pool/main/v/viewres/viewres_1.0.1-0ubuntu2_i386.deb  连接失败
无法下载 http://ubuntu.csie.ntu.edu.tw/ubuntu/pool/main/x/xlogo/xlogo_1.0.1-0ubuntu2_i386.deb  连接失败
无法下载 http://ubuntu.csie.ntu.edu.tw/ubuntu/pool/main/o/openal/libopenal0a_0.0.8-4ubuntu2_i386.deb  连接失败
无法下载 http://ubuntu.csie.ntu.edu.tw/ubuntu/pool/main/b/brltty/libbrlapi1_3.7.2-7.1ubuntu1_i386.deb  连接失败
无法下载 http://ubuntu.csie.ntu.edu.tw/ubuntu/pool/main/x/xserver-xorg-video-apm/xserver-xorg-video-apm_1.1.1-7_i386.deb  连接失败
无法下载 http://ubuntu.csie.ntu.edu.tw/ubuntu/pool/main/p/pppconfig/pppconfig_2.3.17ubuntu1_all.deb  连接失败
无法下载 http://ubuntu.csie.ntu.edu.tw/ubuntu/pool/main/p/python-stdlib-extensions/python-gdbm_2.5.1-1ubuntu1_i386.deb  连接失败
无法下载 http://ubuntu.csie.ntu.edu.tw/ubuntu/pool/universe/g/gcj-4.1/gij-4.1_4.1.2-16ubuntu2_i386.deb  连接失败
无法下载 http://ubuntu.csie.ntu.edu.tw/ubuntu/pool/main/m/mono/libmono-cairo1.0-cil_1.2.4-6ubuntu6_all.deb  连接失败
E: 有几个软件包无法下载,您可以运行 apt-get update 或者加上 --fix-missing 的选项再试试?


懂的不多,我都无奈了
知道解决方法的或能提供点建议的人,可以告诉我到底怎么回事吗

[/code]


_________________
a new world,a new start……


最后由 来年鱼 编辑于 2007-10-22 8:48,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-21 12:38 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
换一个源
sudo apt-get update
后继续


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-10-21 12:45 
头像

注册: 2007-08-07 9:47
帖子: 30
地址: 广东茂名
送出感谢: 0 次
接收感谢: 0 次
试过换源的了
原来是用台湾的
后来换cn99的
还是一样啊
都是无法下载


_________________
a new world,a new start……


最后由 来年鱼 编辑于 2007-10-21 12:53,总共编辑了 1 次

页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-10-21 12:49 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
能上网否


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-10-21 12:55 
头像

注册: 2007-08-07 9:47
帖子: 30
地址: 广东茂名
送出感谢: 0 次
接收感谢: 0 次
可以啊
去把那几个无法下载的包给下了放到某地方?
可我不知道这路径啊


_________________
a new world,a new start……


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-10-21 13:28 
头像

注册: 2007-06-02 14:56
帖子: 547
送出感谢: 0 次
接收感谢: 0 次
网络不稳定的话,建议换源同步后,先把需要的文件下载下来:
sudo apt-get -d dist-upgrade

再升级:
sudo apt-get install update-manager-core
sudo do-release-upgrade

这样即使中途网络中断,升级都不受影响。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-10-21 13:51 
头像

注册: 2007-08-07 9:47
帖子: 30
地址: 广东茂名
送出感谢: 0 次
接收感谢: 0 次
问题就是下载不了啊
而用sudo do-release-upgrade 的话
会卸载一些我不想删的软件啊


_________________
a new world,a new start……


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-10-21 13:55 
头像

注册: 2007-08-07 9:47
帖子: 30
地址: 广东茂名
送出感谢: 0 次
接收感谢: 0 次
现在又有另一个问题
代码:
 无法连接上 cn.archive.ubuntu.com:80 (222.73.255.64),连接超时
获取:15 http://ftp.sjtu.edu.cn gutsy/multiverse Packages [158kB]             
错误 http://cn.archive.ubuntu.com feisty-backports/main/debian-installer Translation-zh_CN
  无法连接上 cn.archive.ubuntu.com:80 (222.73.255.64),连接超时


换了好几个源都这样的结果 :cry:


_________________
a new world,a new start……


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-10-21 15:24 
头像

注册: 2007-08-07 9:47
帖子: 30
地址: 广东茂名
送出感谢: 0 次
接收感谢: 0 次
我怎么搜也找不到类似的
没有人遇到过同样的问题吗


_________________
a new world,a new start……


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-10-21 16:45 

注册: 2006-04-14 1:12
帖子: 88
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
来年鱼 写道:
可以啊
去把那几个无法下载的包给下了放到某地方?
可我不知道这路径啊


/var/cache/apt/archives

尝试终端下使用命令:sudo cp ***.deb /var/cache/apt/archives
sudo apt-get dist-upgrade

或者直接sudo dpkg -i **.deb


_________________
图片
the flying flower
that
changes the colour of my day


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-10-21 20:39 
头像

注册: 2007-08-07 9:47
帖子: 30
地址: 广东茂名
送出感谢: 0 次
接收感谢: 0 次
vision 写道:
来年鱼 写道:
可以啊
去把那几个无法下载的包给下了放到某地方?
可我不知道这路径啊


/var/cache/apt/archives

尝试终端下使用命令:sudo cp ***.deb /var/cache/apt/archives
sudo apt-get dist-upgrade

或者直接sudo dpkg -i **.deb


这样可以吗
我试试
希望能行 :lol:


_________________
a new world,a new start……


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-10-22 8:46 
头像

注册: 2007-08-07 9:47
帖子: 30
地址: 广东茂名
送出感谢: 0 次
接收感谢: 0 次
我用sudo apt-get -d dist-upgrade把需要的文件下了
然后用好几次sudo apt-get dist-upgrade来升级
期间换了两三次源
似乎总算全都升级完事了
松一口气啊
谢谢各位了


_________________
a new world,a new start……


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译