内核依赖树???? Is the kernel headers package installed ?

为当前最终发行版之前的所有版本提供支持
回复
soledad7298
帖子: 16
注册时间: 2007-08-31 8:56
送出感谢: 0
接收感谢: 0

内核依赖树???? Is the kernel headers package installed ?

#1

帖子 soledad7298 » 2007-10-22 16:58

我想重新编译一个我的应用软件
在终端输入./configure --enable-run-in-place
命令后出现错误
.
...
......
checking for stdint.h... yes
checking for unistd.h... yes
checking /usr/src/linux-headers-2.6.15-magma/include/linux/version.h usability... no
checking /usr/src/linux-headers-2.6.15-magma/include/linux/version.h presence... no
checking for /usr/src/linux-headers-2.6.15-magma/include/linux/version.h... no
configure: error: version.h not found - Is the kernel headers package installed ?
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
同事说我的内核依赖树没有安装 他检查了在/usr/src下缺少一个文件(叫什么名字,我不清楚)

我想问一下是内核依赖树没有安装的原因吗?是的话,我要怎么样安装?
还有个问题,就是内核依赖树是每个应用程序都要安装一个 还是一个系统只有一个内核依赖树?
内核依赖树到底有什么作用??


谢谢赐教~~
soledad7298
帖子: 16
注册时间: 2007-08-31 8:56
送出感谢: 0
接收感谢: 0

#2

帖子 soledad7298 » 2007-10-22 16:59

顺便说一下 我的ubuntu的版本在上面有显示
回复

回到 “老旧版本支持”