Ubunut出错啦。。。。

为当前最终发行版之前的所有版本提供支持
回复
ekinwt
帖子: 7
注册时间: 2007-07-24 13:36
送出感谢: 0
接收感谢: 0

Ubunut出错啦。。。。

#1

帖子 ekinwt » 2007-10-23 15:12

执行apt-get install -f 时出错啦。。

root@ProvenceServer:/usr/bin# apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
postfix
Suggested packages:
procmail postfix-mysql postfix-pgsql postfix-ldap postfix-pcre sasl2-bin resolvconf postfix-cdb
The following NEW packages will be installed:
postfix
0 upgraded, 1 newly installed, 0 to remove and 33 not upgraded.
6 not fully installed or removed.
Need to get 0B/1119kB of archives.
After unpacking 2589kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Preconfiguring packages ...
(Reading database ... 112311 files and directories currently installed.)
Unpacking postfix (from .../postfix_2.4.5-3~feisty1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/postfix_2.4.5-3~feisty1_i386.deb (--unpack):
unable to create `./usr/sbin/postalias': Permission denied
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/postfix_2.4.5-3~feisty1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
头像
bones7456
论坛版主
帖子: 8495
注册时间: 2006-04-12 20:05
来自: 杭州
送出感谢: 0
接收感谢: 8 次
联系:

#2

帖子 bones7456 » 2007-10-23 15:30

你是要装 postfix ?
先sudo apt-get remove postfix 删掉这个包,再 sudo rm /var/cache/apt/archives/postfix_2.4.5-3~feisty1_i386.deb 删掉缓存的文件,再 sudo apt-get install postfix 试试.
关注我的blog: ε==3
ekinwt
帖子: 7
注册时间: 2007-07-24 13:36
送出感谢: 0
接收感谢: 0

#3

帖子 ekinwt » 2007-10-23 16:33

执行删除操作的结果如下,还是不行呢。
root@ProvenceServer:/var/cache/apt/archives# apt-get remove mailx postfix
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package mailx is not installed, so not removed
Package postfix is not installed, so not removed
The following packages will be REMOVED:
initscripts upstart upstart-compat-sysv upstart-logd
0 upgraded, 0 newly installed, 4 to remove and 1 not upgraded.
4 not fully installed or removed.
Need to get 0B of archives.
After unpacking 1057kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 112286 files and directories currently installed.)
Removing upstart-compat-sysv ...
dpkg: error processing upstart-compat-sysv (--remove):
cannot remove `/sbin/poweroff': Permission denied
Removing initscripts ...
dpkg: error processing initscripts (--remove):
cannot remove `/bin/mountpoint': Permission denied
Removing upstart-logd ...
dpkg: error processing upstart-logd (--remove):
cannot remove `/sbin/logd': Permission denied
Removing upstart ...
dpkg: error processing upstart (--remove):
cannot remove `/sbin/status': Permission denied
Errors were encountered while processing:
upstart-compat-sysv
initscripts
upstart-logd
upstart
E: Sub-process /usr/bin/dpkg returned an error code (1)
头像
goldfox_79
帖子: 1937
注册时间: 2005-10-16 8:26
来自: 地球
送出感谢: 0
接收感谢: 1 次
联系:

#4

帖子 goldfox_79 » 2007-10-24 11:46

我有点不明白第一个帖子里面的
unable to create `./usr/sbin/postalias': Permission denied
".usr/sbin"是什么目录啊

用户组被设置乱了?[/quote]
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#5

帖子 xiehuoli » 2007-10-24 11:48

goldfox_79 写了:我有点不明白第一个帖子里面的
unable to create `./usr/sbin/postalias': Permission denied
".usr/sbin"是什么目录啊

用户组被设置乱了?
[/quote]
他应该是cd 到那个目录而已把
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
ekinwt
帖子: 7
注册时间: 2007-07-24 13:36
送出感谢: 0
接收感谢: 0

#6

帖子 ekinwt » 2007-10-24 11:50

没呢,我就是安装的时候就会出现那样的错误,我也觉得可能是用户组的权限被打乱了,那要怎么改回来呢?
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#7

帖子 xiehuoli » 2007-10-24 11:52

你都干过些什么?
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
ekinwt
帖子: 7
注册时间: 2007-07-24 13:36
送出感谢: 0
接收感谢: 0

#8

帖子 ekinwt » 2007-10-24 12:57

我啥都没干,某天起来就变成那个样子了,所有的东东都安装不上去,使用apt-get都会出现那样的提示。
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#9

帖子 xiehuoli » 2007-10-24 13:35

ekinwt 写了:我啥都没干,某天起来就变成那个样子了,所有的东东都安装不上去,使用apt-get都会出现那样的提示。
中毒?黑客?
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
ekinwt
帖子: 7
注册时间: 2007-07-24 13:36
送出感谢: 0
接收感谢: 0

#10

帖子 ekinwt » 2007-10-24 13:57

都很有可能。。。。。
看看有啥办法可以解决下。。。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#11

帖子 eexpress » 2007-10-30 11:21

附近找一个ub。复制比较下/etc/passwd 和 group文件。试试。
● 鸣学
ekinwt
帖子: 7
注册时间: 2007-07-24 13:36
送出感谢: 0
接收感谢: 0

#12

帖子 ekinwt » 2007-10-30 11:46

和别的ubuntu对照了一下,没有什么问题,都是一样的。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#13

帖子 eexpress » 2007-10-30 12:29

你怎么是英文locale啊。

以后,你别apt-get。都用aptitude吧。依赖等方面好些。智能些。


☎ alias|grep aptitude
alias ag='sudo aptitude safe-upgrade'
alias ai='sudo aptitude install'
alias ar='sudo aptitude remove --purge'
alias as='aptitude search'
alias au='sudo aptitude update'
alias aw='aptitude show'
● 鸣学
回复

回到 “老旧版本支持”