求助关于APT-GET问题

为当前最终发行版之前的所有版本提供支持
回复
coldphn
帖子: 6
注册时间: 2006-01-02 9:17
送出感谢: 0
接收感谢: 0

求助关于APT-GET问题

#1

帖子 coldphn » 2006-01-02 9:21

以前安装gstreamer0.8-plugins时出现过错误,现在再安装其他的都会提示如下:

~$ sudo apt-get install rar
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
gstreamer0.8-plugins: 依赖: gstreamer0.8-visuals (>= 0.8.11) 但是它将不会被安 装
rar: 依赖: libstdc++5 (>= 1:3.3.4-1) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

运行apt-get -f install时,提示

$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 完成
将会安装下列的额外的软件包:
gstreamer0.8-visuals
下列【新】软件包将被安装:
gstreamer0.8-visuals
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 78 个软件未被升 级。
有 4 个软件包没有被完全安装或卸载。
需要下载 0B/63.0kB 的软件包。
解压缩后会消耗掉 176kB 的额外空间。
您希望继续执行吗?[Y/n]y
【警告】:下列的软件包不能通过认证!
gstreamer0.8-visuals
不经验证就安装这些软件包么?[y/N] y

正在预设定软件包 ...
(正在读取数据库 ... 系统当前总共安装有 60361 个文件和目录。)
正在解压缩 gstreamer0.8-visuals (从 .../gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/gstreamer-0.8/libgstgoom.so”,它属于软件包 gstreamer0.8-misc
在处理时有错误发生:
/var/cache/apt/archives/gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.debE: Sub-process /usr/bin/dpkg returned an error code (1)


请大家帮帮忙,谢谢!
回复

回到 “老旧版本支持”