当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]Ip地址怎么设置?
帖子发表于 : 2007-10-27 23:01 

注册: 2007-10-27 17:14
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
我装上ubuntu7.10两天了,有一个问题折腾两天,查看了很多资料都没有搞定!盼望得到指点。问题如下:
我用的网卡是U.S.R 的PCI 5416无线网卡,能找到信号,但IP Address DNS等不知怎么设置。用sudo pppoeconf代码查得以太设备有两个:eth0和wlan0。用sudo gedit /etc/network/interfaces在root下更改成如下内容:auto wlan0
iface wlan0 inet static
address 192.168.1.102
gateway 192.168.1.1
netmask 255.255.255.0
保存。无线网卡能接收到信号。但ip等还是老样。无法上网!!
(ip等数据是事先在windowsxp查到的)
参看的文章是:“图解Ubuntu 7.10安装配置、ubuntu的网卡设置、ubuntu全局配置文件、分辨率调整”等文章。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-28 0:04 

注册: 2007-10-27 23:56
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
右上角 或者在 网络管理 里有相应参数修改GUI。


页首
 用户资料  
 
3 楼 
 文章标题 : [问题]
帖子发表于 : 2007-10-28 10:08 

注册: 2007-10-27 17:14
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
freefis 写道:
右上角 或者在 网络管理 里有相应参数修改GUI。

没能解决,能否给点详细些的具体操作方法。先谢过了!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-10-28 22:17 

注册: 2007-10-18 19:15
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
我用有线连接 也有 类似的问题!

解决方法

选择 “漫游模式”//不要用静态IP!

再手动设置DNS//不能上网 主要就是 DNS设置的 不对,每个地区的 DNS都是不一样的!


页首
 用户资料  
 
5 楼 
 文章标题 : [问题]
帖子发表于 : 2007-11-02 18:55 

注册: 2007-10-27 17:14
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
Never2Die 写道:
我用有线连接 也有 类似的问题!

解决方法

选择 “漫游模式”//不要用静态IP!

再手动设置DNS//不能上网 主要就是 DNS设置的 不对,每个地区的 DNS都是不一样的!



试了一下,不过自动模式,还是无法获得ip、子码掩码、网关等信息!活动连接信息显示全是0.0.0.0硬件地址倒是对的。都有点绝望了。另外在sonyVGN-B99C的本子上装的ubuntu在办公室里却能获得ip、子码掩码、网关等的正确信息。并且能够上网,更新也正常!!可惜hotkey Fn+F7功能(切换的投影机)无效,使得我不能用本子给学生上课,不知有没有解决之道。我的台式机的DNS是起先在windows下获得并记录下来的,没有错的。


页首
 用户资料  
 
6 楼 
 文章标题 : [讨论]Re: [问题]
帖子发表于 : 2007-11-14 9:43 

注册: 2007-10-27 17:14
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
今天终于搞定了家里台式机无线上网的问题了。结合大家的办法,具体如下:

我的静态ip地址设置过程如下:
1、单击网络图标,选择手动配置,选中“连接”选项的无线连接,左击“属性”去除“启动漫游模式”前面的勾。往下是“网络名称”选择计算机自己发现的名称之一(我的计算机只发现一个无线信号TP-LINK),
“密码类型”选择“WPA persenal“网络密码”为空。“connection setting”选择“配置静态ip地址”然后输入事先查找出来的信息(我是新手所以是在windows下查出来的)
我信息如下:
ip地址:192.168.1.102
广播地址:255.255.255.255
子码掩码:255.255.255.0
默认路由:192.168.1.1
主DNS:192.168.1.1 (此条和windows下查出来的大有出入windows告诉我的是主DNS:61.153.177.210备用DNS:61.153.177.209,按此设置无法上网,为此我费劲心力才查资料搞定!断断续续用时将近20天,走了
说不清楚多少弯路,几乎要到绝望而放弃的地步!!)
辅DNS:0.0.0.0
硬件地址:00.12.F0.5A.F9.67(计算机自己给出的)
然后选择第二项“常规”主机名填你喜欢的(我的是zhgagen-desktop)域名应该为空(我原来设为:192.168.1.1不能上网,改成 空 就能上网了。)
接下来是“DNS”
选“添加”根据实际输入。(我的输入值为:192.168.1.1)
最后是“主机”我输入的是:192.168.1.102 localhost ipv-loopback(我原来不能上网时以为这里有问题修改成这个样子,实际上输入什么是没有关系的)





zhgagen 写道:
Never2Die 写道:
我用有线连接 也有 类似的问题!

解决方法

选择 “漫游模式”//不要用静态IP!

再手动设置DNS//不能上网 主要就是 DNS设置的 不对,每个地区的 DNS都是不一样的!



试了一下,不过自动模式,还是无法获得ip、子码掩码、网关等信息!活动连接信息显示全是0.0.0.0硬件地址倒是对的。都有点绝望了。另外在sonyVGN-B99C的本子上装的ubuntu在办公室里却能获得ip、子码掩码、网关等的正确信息。并且能够上网,更新也正常!!可惜hotkey Fn+F7功能(切换的投影机)无效,使得我不能用本子给学生上课,不知有没有解决之道。我的台式机的DNS是起先在windows下获得并记录下来的,没有错的。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-03-30 23:38 
头像

注册: 2007-09-02 18:54
帖子: 180
地址: ghtxx.cn
送出感谢: 1
接收感谢: 0 次
DNS概念楼上的没理解吧,,,
其实如果你的局域网中有DHCP功能,这些都不用你手工设置,看看你的路由,应该是可用的呀。

DNS IP建议使用opendns:https://www.opendns.com/start


_________________
Life is a gift.
一起到我们的Linux学习MSN群中来吧:加linux@ghtxx.cn为好友讨论。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译