当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 62 篇帖子 ]  前往页数 1, 2, 3, 4, 5  下一页
作者 内容
1 楼 
 文章标题 : 如果你的硬盘频繁启动关闭休眠,那么很容易造成硬盘机械故障。
帖子发表于 : 2007-10-28 9:16 

注册: 2007-01-28 21:27
帖子: 216
送出感谢: 0 次
接收感谢: 0 次
Laptop Hardrive Killer Bug is worse than I thought
http://ubuntudemon.wordpress.com/2007/1 ... i-thought/

Laptop Hardrive Killer Bug - should get critical status
http://ubuntudemon.wordpress.com/2007/1 ... al-status/

Bug #59695 in acpi-support
https://bugs.launchpad.net/ubuntu/+sour ... omments/25

default value in power.sh potentially kills laptop disks
https://bugs.launchpad.net/ubuntu/+sour ... omments/14

what Matthew Garret an Ubuntu Developer has said about this problem
http://www.advogato.org/person/mjg59/diary/82.html

Ubuntu is NOT causing aggressive power management
http://ubuntudemon.wordpress.com/2007/1 ... ment-31617

以上都讨论了如果设置不当,UBUNTU会损坏你的笔记本硬盘

How to make use of Harddisk Power Management features
http://www.thinkwiki.org/wiki/How_to_ma ... t_features

由于反应可能无法打开第一个链接,现直接贴上内容
Laptop Hardrive Killer Bug - How to discover whether you are affected
笔记本硬盘杀手-如何发现你是否也有这个问题?

Your harddisk shouldn’t spin-down/spin-up and/or park/unpark too much causing the mechanics of the harddrive to slowly detiorate. If this is happening you should see your Load_Cycle_Count increasing too fast.
如果你的硬盘频繁启动关闭休眠,那么很容易造成硬盘机械故障。如果发现磁盘有异常,你可以检查磁盘的Load_Cycle_Count 是否增加的太快了

The following things might cause aggressive power management :
以下几个方面可能造成电源管理上的问题

* your (laptop) harddrive firmware might have aggressive power management defaults (operating system independent)
你的(笔记本)硬盘默认设置就是这样的
* your (laptop) BIOS might set your harddrive to use aggressive power management (operating system independent)
你的(笔记本)的BIOS设置使用这个电源管理方式(和系统没有关系)
* you might have enabled laptop-mode in /etc/default/acpi-support (disabled by default) which will set your harddrive to use aggressive power management
你激活了laptop-mode模式,这个在 /etc/default/acpi-support中(默认是关闭的)

There’s another part of this problem (one of the following might be true) :
以下方面也有可能造成这个问题(没确定)

* something wakes up the harddrive right after spinning down.
硬盘关闭后,有些动作会唤醒硬盘
* something unparks the head right after your harddisk head is parked.
硬盘休眠后,有些动作会唤醒硬盘

To discover whether you suffer from this problem :
检查你是否有同样的问题

First install smartmontools to be able to query your harddrive :
第一安装上工具smartmontools
$
代码:
sudo aptitude install smartmontools


To find your Load_Cycle_Count do this (the last number is the number we are interested in) :
去检查你的Load_Cycle_Count你的,最后一个数据
$
代码:
sudo smartctl -a /dev/sda | grep Load_Cycle_Count


If this number is growing rapidly (more than 90 per day) then you suffer from this problem.
这个数据增加得很快(一天超过90),那说明你有问题

My harddrive started to slowly die when at a Load_Cycle_Count of 200.000 after 10 months of use (Feisty and a little bit of Gutsy).
10个月后,Load_Cycle_Count 有200.000次,我硬盘的寿命也快到了

The reason I’m estimating to watch out for values above 90 per day is because it will guarantee that your Load_Cycle_Count is less than 100.000 in three years : 90 * 365 * 3 = 98550 Which almost guarantees that your harddrive won’t die during the first three years due to a high Load_Cycle_Count.
我是这样计算的,一天在90次以下,三年就是98550次,这样用三年没问题

IMHO this bug should get critical status because it’s killing people’s harddrives.
IMHO提交的BUG应该加以关注

More information about this bug :
其他关于这个BUG的信息

* https://bugs.launchpad.net/ubuntu/+sour ... +bug/59695
* http://www.advogato.org/person/mjg59/diary/82.html
* http://ubuntudemon.wordpress.com/2007/1 ... killer-bug
* http://ubuntudemon.wordpress.com/2007/1 ... -i-thought

根据最新消息,只是UBUNTU 采用了磁盘或BIOS的默认设置,而由于默认的不当设置,造成这个问题
建议UBUNTU 以后可以用系统设置覆盖这些默认的设置


attached another article
HDD Wearing and Tearing Down
The problem
A while ago, it was confirmed that Linux running on some laptops is wearing and tearing down their hard drives. At first, it was thought that this is only an Ubuntu issue and therefore, a bug was posted on launchpad. However, after the problem was deeper analyzed, it came up that the problem was generated by faulty ACPI configuration so don’t act surprised if you run into other distributions that have the same or similar bad ACPI configs. ACPI stands for Advanced Configuration and Power Interface.

So what’s really happening? Well, if you’re running Linux on a laptop and unplug its power source, leaving it to run on batteries, the operating system (ACPI to be more exact) is applying several settings to get a longer life time. I’m not sure about other distributions but Ubuntu’s ACPI issues the hdparm -B 1 command to all block devices, leading to extremely frequent load cycles.

To give you some statistics: the drive is rated for 600,000 load/unload cycles, and after 2.5 months of running Feisty I’m already at more than 56,000 load/unload cycles (and only 150 power cycles), according to the SMART data. At this rate the drive will be dead after 2.5 years, and I don’t even use this computer for more than a couple of hours each day.

Are YOU affected?

If you’re running Ubuntu, you should know that the only way to see the number of load cycles is by using SMART tools which aren’t even installed by default. To install them, simply run:

$ sudo apt-get install smartmontools

Now, to find your drive’s load cycle count, run this command in a terminal (replace /dev/sda to suit your computer configuration, /dev/hda for example if you have ata drive):

$ sudo smartctl -a /dev/sda | grep Load_Cycle_Count

You should see an output like this:
193 Load_Cycle_Count 0x0012 095 095 000 Old_age Always - 55380

In this example, 55380 is the load cycle count which SHOULD increase by 3-5 in an HOUR. But if it’s increasing by 3, 5 or more in a MINUTE, there’s definitely a problem. Think about it: HDD manufactures are claiming that a drive will support about 600.000 load cycles, meaning that your drive should be fine for a few years. But when the count is increasing by 3 cycles every minute (180 per hour), things should go bad after 3333 hours. That’s ONLY 138 DAYS! That’s VERY BAD!


The solution

First of all, you should edit the /etc/acpi/power.sh file. Open it with your favorite editor and edit the following line (actually, there are two identical lines, edit them both):
$HDPARM -B 1 /dev/$drive 2>/dev/null

to

$HDPARM -B 255 /dev/$drive 2>/dev/null

To make sure everything is right and your drive is safe, also follow these steps:
# create a file called 99-hdd-cycle-fix.sh (the 99 is mandatory) and make it executable:

$ touch 99-hdd-cycle-fix.sh
$ chmod +x 99-hdd-cycle-fix.sh
# open it with your favorite text editor and paste these lines (again, make sure it suits your drive configuration - you might need /dev/hda or such):

#!/bin/sh
hdparm -B 255 /dev/sda
# copy the file to three locations:

$ sudo cp 99-hdd-cycle-fix.sh /etc/acpi/suspend.d/
$ sudo cp 99-hdd-cycle-fix.sh /etc/acpi/resume.d/
$ sudo cp 99-hdd-cycle-fix.sh /etc/acpi/start.d/

Keep in mind however that the 255 setting will totally switch off power management for your drive. This means that it will suck more power, decreasing the laptop’s battery life and it will make the drive a bit more vulnerable (it’s likely you’ll get bad sectors if you drop the laptop but this won’t happen, now, will it:).

There you go, your drive should now rest peacefully.


最后由 helai 编辑于 2008-01-05 14:47,总共编辑了 11 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-28 9:31 

注册: 2006-08-22 2:07
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
强帖!首页留名。
如果是真的话,那真要留意了。
我只知道关机的那刻硬盘机械归位有声音的。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-10-28 10:47 

注册: 2006-12-22 20:44
帖子: 183
送出感谢: 0 次
接收感谢: 0 次
第一个url看不到,到底是怎么回事情?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-10-28 11:24 

注册: 2006-08-22 2:07
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
1.打不开

2.default value in power.sh potentially kills laptop disks

As a temporary fix I edited /etc/hdparm.conf and added:

/dev/sda {
apm = 255
spindown_time = 0
}

Afterwards I installed the hdparm init script by doing 'sudo update-rc.d hdparm defaults' to make the changes consistent over reboots.

This is the same as running the following commands:
hdparm -B255 /dev/sda
hdparm -S0 /dev/sda

This will turn off Advanced Power Management on the drive and it will disable the standby (spindown) timeout, so the drive will never be spun down and up again.

3.default value in power.sh potentially kills laptop disks

Here is how I permanently fixed it:

1) make a file named "99-hdd-spin-fix.sh". The important thing is starting with "99".
2) make sure the file contains the following 2 lines (fix it if you have PATA HDD):
#!/bin/sh
hdparm -B 255 /dev/sda
3) copy this file to 3 locations:
/etc/acpi/suspend.d/
/etc/acpi/resume.d/
/etc/acpi/start.d/

Voila! After that the HDD never spins down on power (looks like it actually spins down on battery at modest rate).
Sorry if the instruction is too detailed, no offense.


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-10-28 14:08 
头像

注册: 2007-10-09 17:34
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
不是真的吧。。。。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-10-28 14:17 
头像

注册: 2006-12-23 13:46
帖子: 9203
地址: Azores Islands
送出感谢: 0 次
接收感谢: 1
引用:
To discover whether you suffer from this problem :

First install smartmontools to be able to query your harddrive :
$ sudo aptitude install smartmontools

To find your Load_Cycle_Count do this (the last number is the number we are interested in) :
$ sudo smartctl -a /dev/sda | grep Load_Cycle_Count

If this number is growing rapidly (more than 90 per day) then you suffer from this problem.


_________________
no security measure is worth anything if an attacker has physical access to the machine


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-10-28 14:50 

注册: 2007-02-18 13:13
帖子: 170
送出感谢: 0 次
接收感谢: 0 次
这是什么意思,英文看不懂啊,有人翻译吗,到底是啥问题,解决方法有吗


_________________
good good study,day day up
贯彻中国式英语


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-10-28 15:10 
头像

注册: 2007-06-10 8:28
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
如果设置了
hdparm -B255 /dev/sda
hdparm -S0 /dev/sda
如何恢复默认设置?
sudo update-rc.d hdparm defaults ???


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-10-28 16:12 
头像

注册: 2006-12-23 13:46
帖子: 9203
地址: Azores Islands
送出感谢: 0 次
接收感谢: 1
背景: 

  本本工作在电池模式时,本本硬盘的电源管理会在一定条件下频繁地unload 磁头或硬盘供电,ext 3 是日志型文件系统, 硬盘上还有swap,加上其它个别进程等等原因,会让刚刚睡觉的硬盘马上唤醒。


争论的问题



如果这种硬盘unload/load动作的频率太高,有可能会缩短硬盘的寿命。



luachpad 上貌似也不是太热闹,当然回帖中强硬派不少,大致情况如下:


 1 ,本本专用硬盘的特性与台式机硬盘不同,本本专用硬盘经常会unload硬盘,这是为了让硬盘在本本这种环境中寿命更长,比如防止意外碰撞,跌落时的情况发生,所以本本专用硬盘可经受频繁的load/ unload , 特殊的设计会让本本专用硬盘在这方面的寿命要比台式机硬盘的寿命要长得多。所以不用把它当回事

 2 强硬派认为这样会样会缩短硬盘的寿命,回帖中有人说硬盘这种寿命只有600K 次



我的观点:


 还是咨询一下硬盘厂商的技术支持部门: 硬盘厂商说没事,那就没事。

 如果没搞清楚前,你不放心,那就不要开启节电模式,使用相应的脚本,或者用硬盘厂商的专用工具,关闭这一模式或修改相关参数。

 



 这一问题从很古老的ubuntu一直到ubuntu 7.10都存在,到底能让多少硬盘挂掉呢?  论坛大量的本本用户长期用ubuntu上网,amule .泡论坛,我相信 时间能告诉我们答案。

如果你不知道如何看待或避免这类问题,或者本来就对开源系统没信心,只是打算玩一下linux桌面,那还是回到windows去吧。


_________________
no security measure is worth anything if an attacker has physical access to the machine


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-10-28 17:35 

注册: 2007-02-18 13:13
帖子: 170
送出感谢: 0 次
接收感谢: 0 次
原来如此


_________________
good good study,day day up
贯彻中国式英语


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-10-28 22:09 

注册: 2007-10-22 0:12
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
skyx 写道:
背景: 

  本本工作在电池模式时,本本硬盘的电源管理会在一定条件下频繁地unload 磁头或硬盘供电,ext 3 是日志型文件系统, 硬盘上还有swap,加上其它个别进程等等原因,会让刚刚睡觉的硬盘马上唤醒。


争论的问题



如果这种硬盘unload/load动作的频率太高,有可能会缩短硬盘的寿命。



luachpad 上貌似也不是太热闹,当然回帖中强硬派不少,大致情况如下:


 1 ,本本专用硬盘的特性与台式机硬盘不同,本本专用硬盘经常会unload硬盘,这是为了让硬盘在本本这种环境中寿命更长,比如防止意外碰撞,跌落时的情况发生,所以本本专用硬盘可经受频繁的load/ unload , 特殊的设计会让本本专用硬盘在这方面的寿命要比台式机硬盘的寿命要长得多。所以不用把它当回事

 2 强硬派认为这样会样会缩短硬盘的寿命,回帖中有人说硬盘这种寿命只有600K 次



我的观点:


 还是咨询一下硬盘厂商的技术支持部门: 硬盘厂商说没事,那就没事。

 如果没搞清楚前,你不放心,那就不要开启节电模式,使用相应的脚本,或者用硬盘厂商的专用工具,关闭这一模式或修改相关参数。

 



 这一问题从很古老的ubuntu一直到ubuntu 7.10都存在,到底能让多少硬盘挂掉呢?  论坛大量的本本用户长期用ubuntu上网,amule .泡论坛,我相信 时间能告诉我们答案。

如果你不知道如何看待或避免这类问题,或者本来就对开源系统没信心,只是打算玩一下linux桌面,那还是回到windows去吧。
恐怖


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-10-29 7:45 
头像

注册: 2007-06-10 8:28
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
本本hdparm默认的配置参数是多少?
昨天没仔细看就试了一下,忘了cp了,
hdparm -B255 /dev/sda
hdparm -S0 /dev/sda
如何改回默认的参数了?


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-10-29 11:08 

注册: 2006-06-23 18:19
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
我在6.10版用到电池的时候,硬盘会停转以省电,后来的版本似乎没碰到过。
7.10还没有跑过电池。下次看看。


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-10-29 11:13 
头像

注册: 2007-10-21 18:36
帖子: 3235
地址: 汕头/广东/中国
送出感谢: 2
接收感谢: 3
我凡用LINUX ,硬盘声音就出来,像沙子落下的声音。
Windows的时候没有声音。


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-10-29 11:17 
头像

注册: 2007-10-21 18:36
帖子: 3235
地址: 汕头/广东/中国
送出感谢: 2
接收感谢: 3
225 Load_Cycle_Count 0x0032 100 100 000 Old_age Always - 5851

不知道是225还是5851?如果是后者的话……


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 62 篇帖子 ]  前往页数 1, 2, 3, 4, 5  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译