请高手讲讲apt-build

为当前最终发行版之前的所有版本提供支持
回复
howlym
帖子: 35
注册时间: 2005-12-01 16:41
送出感谢: 0
接收感谢: 0

请高手讲讲apt-build

#1

帖子 howlym » 2006-01-05 15:28

ubuntu很方便,但就是觉得慢,有些软件用apt-get装后不稳定,所以我一直在想如果ubuntu有两套安装系统就好了,一套是现行的apt-get系统,一套是类似于Freebsd,Gentoo,Archlinux那样的源码编译系统,我们的服务器一直是用FreeBSD的,所以知道编译出来的程序非常稳定,后来FreeFly在回复我的一篇帖子中介绍了apt-build,我试用了一下,发现几个问题,请高手指教:
1.apt-build不是官方程序
2.装后我试用了一下,几乎我想要编译的东西,都没法编译 ???
3.apt-build后,会不会在新立德(或其他地方)里面进行卸载,我的意思是,安装的软件包是否可以管理

请指教~!
头像
millenniumdark
论坛版主
帖子: 4160
注册时间: 2005-07-02 14:41
系统: Ubuntu 14.04 (Kylin)
送出感谢: 43 次
接收感谢: 9 次
联系:

#2

帖子 millenniumdark » 2006-01-16 23:52

If you just want to manger softwares which you building by apt-get, just install checkinstall and use checkinstall to replace make install.
http://www.ubuntu.org.cn/support/docume ... eckInstall
owenchn
帖子: 26
注册时间: 2006-01-16 14:41
送出感谢: 0
接收感谢: 0

#3

帖子 owenchn » 2006-01-19 16:59

知到了,谢谢
回复

回到 “老旧版本支持”