为什么没有一个权威的开发环境配置说明呢?

为当前最终发行版之前的所有版本提供支持
回复
头像
wangguangping
帖子: 259
注册时间: 2006-05-10 16:01
来自: 安徽合肥
送出感谢: 0
接收感谢: 0

为什么没有一个权威的开发环境配置说明呢?

#1

帖子 wangguangping » 2007-10-31 10:37

为什么没有一个权威的开发环境配置说明呢?

说句实话,无论ubuntu的新立德还是古老的aptitude,这些工具都没有解决一个很简单却很基本的问题,那就是没能把源里面的软件包进行严格的分类分组,现在的分类实在太过笼统,模块划分不清晰。比如我想建个C/C++开发环境,那么我究竟该选那些包apt-get,才算完整,包括文档等。如果我想建个gtk开发环境 ,究竟哪些包是gtk的,而不是QT的。在现有的源中,笼统的算作developer,这实在太不清楚的。另外,我们现在如果建这么个开发环境,往往是参考网上朋友的帖子,这几乎毫无权威性,很容易遗漏包,库之类的。

谁能提供一个详细的文档呵?
Z1P
帖子: 40
注册时间: 2007-10-30 12:35
送出感谢: 0
接收感谢: 0

#2

帖子 Z1P » 2007-10-31 10:54

sudo apt-get install build-essential gcc make autoconf automake libtool gdb g++
安装上面的就可以了,开发过程中如果需要什么再装就行了,又没有什么影响。
即便你安装上了所有的包,你又能用到几个?
回复

回到 “老旧版本支持”