[问题]每次apt-get install的时候,都会出现dpkg的错误。

为当前最终发行版之前的所有版本提供支持
回复
echoN
帖子: 2
注册时间: 2006-05-03 12:46
送出感谢: 0
接收感谢: 0

[问题]每次apt-get install的时候,都会出现dpkg的错误。

#1

帖子 echoN » 2007-11-03 11:51

lmsp@hust-lmsp:~$ sudo apt-get install python2.4
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
将会安装下列额外的软件包:
python2.4-minimal
建议安装的软件包:
python2.4-doc python-profiler
下列【新】软件包将被安装:
python2.4 python2.4-minimal
共升级了 0 个软件包,新安装了 2 个软件包,要卸载 0 个软件包,有 10 个软件未被升级。
有 2 个软件包没有被完全安装或卸载。
需要下载 3771kB 的软件包。
解压缩后会消耗掉 12.8MB 的额外空间。
您希望继续执行吗?[Y/n]Y
获取:1 http://debian.ustc.edu.cn hardy/main python2.4-minimal 2.4.4-6ubuntu4 [972kB]
获取:2 http://debian.ustc.edu.cn hardy/main python2.4 2.4.4-6ubuntu4 [2799kB]
下载 3771kB,耗时 0s (4690kB/s)
选中了曾被取消选择的软件包 python2.4-minimal。
(正在读取数据库 ... 系统当前总共安装有 118136 个文件和目录。)
正在解压缩 python2.4-minimal (从 .../python2.4-minimal_2.4.4-6ubuntu4_i386.deb) ...
选中了曾被取消选择的软件包 python2.4。
正在解压缩 python2.4 (从 .../python2.4_2.4.4-6ubuntu4_i386.deb) ...
正在设置 linux-image-2.6.22-14-386 (2.6.22-14.46) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.22-14-386
find: /lib/firmware/2.6.22-14-386: No such file or directory
find: /lib/firmware/2.6.22-14-386: No such file or directory
find: /lib/firmware/2.6.22-14-386: No such file or directory
find: /lib/firmware/2.6.22-14-386: No such file or directory
find: /lib/firmware/2.6.22-14-386: No such file or directory
find: /lib/firmware/2.6.22-14-386: No such file or directory
Running postinst hook script /sbin/update-grub.
Searching for GRUB installation directory ...
No GRUB directory found. To create a template run 'mkdir /boot/grub' first. To install grub, install it manually or try the 'grub-install' command. ### Warning, grub-install is used to change your MBR. ###

User postinst hook script [/sbin/update-grub] exited with value 1
dpkg:处理 linux-image-2.6.22-14-386 (--configure)时出错:
子进程 post-installation script 返回了错误号 1
正在设置 linux-image-2.6.22-14-generic (2.6.22-14.46) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.22-14-generic
Not updating initrd symbolic links since we are being updated/reinstalled
(2.6.22-14.46 was configured last, according to dpkg)
Not updating image symbolic links since we are being updated/reinstalled
(2.6.22-14.46 was configured last, according to dpkg)
Running postinst hook script /sbin/update-grub.
Searching for GRUB installation directory ...
No GRUB directory found. To create a template run 'mkdir /boot/grub' first. To install grub, install it manually or try the 'grub-install' command. ### Warning, grub-install is used to change your MBR. ###

User postinst hook script [/sbin/update-grub] exited with value 1
dpkg:处理 linux-image-2.6.22-14-generic (--configure)时出错:
子进程 post-installation script 返回了错误号 1
正在设置 python2.4-minimal (2.4.4-6ubuntu4) ...
Linking and byte-compiling packages for runtime python2.4...

正在设置 python2.4 (2.4.4-6ubuntu4) ...

Processing triggers for libc6 ...
ldconfig deferred processing now taking place
在处理时有错误发生:
linux-image-2.6.22-14-386
linux-image-2.6.22-14-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

#2

帖子 dbzhang800 » 2007-11-03 13:33

你能不能介绍一下背景,比如里面涉及到的错误是误报还是其他?

个人感觉
既然你都用了1年多ubuntu了,应该不会不装grub的
echoN
帖子: 2
注册时间: 2006-05-03 12:46
送出感谢: 0
接收感谢: 0

#3

帖子 echoN » 2007-11-04 10:22

dbzhang800 写了:你能不能介绍一下背景,比如里面涉及到的错误是误报还是其他?

个人感觉
既然你都用了1年多ubuntu了,应该不会不装grub的
恩,是这样的。
我发现机器没有声音了,然后发现机子的模块中缺少声音的驱动模块,然后我就重新把模块包安装了一回。然后把声卡模块加载成功后,就有声音了。

但是这以后,我每次apt-get install一个东西都会发现它要去修改linux的image和grub,而且会出现类似上面的错误。
回复

回到 “老旧版本支持”